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ASSIGNMENT:  BACKGROUND BRIEFING 
 
On Monday of Week 2, each student will make a five-minute oral presentation on a concept needed to understand 
the readings in this class.  Each student should submit a one-page handout, which will be distributed to the entire 
class.  Each presentation and handout should include the following. 

1. Motivation:  Why is this concept important or useful? 
2. Formal definition:  Use equations to define the concept. 
3. Graph, diagram, or other visual:   Illustrate the concept in a way that makes it easier to understand. 
4. Numerical example:  Given a sample numerical value for the concept, and how would it be interpreted.  If 

possible, show a numerical example of how the value would be computed. 
5. References:  List at least two sources for further reading, if someone wants more detail.  These might 

include pages in a textbook, a Wikipedia article, etc. 
 
An example is attached after the rubric. 
 

Concept Presenter 
(1) Input substitution:  Define and explain a production function with two 
inputs.  Give an example.  Also define and give an example of an isoquant 
diagram.  What is the slope of the isoquant called?  Suggested resource:  
microeconomics textbook or www.wikipedia.org. 

 

(2) Measures of inequality I:  Define and explain variance, standard 
deviation, coefficient of variation.  Suggested resource:  statistics textbook, 
econometrics textbook, or www.wikipedia.org 

 

(3) Measures of inequality II:  Define and explain quantiles, percentiles.  
Suggested resource:  statistics textbook or www.wikipedia.org. 

 

(4) Measures of inequality III:  Define and explain Lorenz curve, Gini 
coefficient.  Suggested resource:  economics textbook or www.wikipedia.org. 

 

(5) Standard error and confidence interval:  Define these concepts for 
coefficient estimates in a regression equation.  Suggested resource:  Angrist 
and Pischke textbook (appendix of chapter 1), econometrics textbook, or 
www.wikipedia.org. 

 

(6) T-statistic and p-value:  Define these concepts for coefficient estimates 
in a regression equation.  Suggested resource:  Angrist and Pischke textbook 
(appendix of chapter 1), econometrics textbook, or www.wikipedia.org. 

 

(7) All variables in logs:  Give the regression equation and explain how to 
interpret coefficients when the  Y  variable and the  X  variable are both 
natural logarithms.  Suggested resource:  econometrics textbook or 
www.wikipedia.org. 

 

(8) Mincer earnings function:  This is a commonly-used econometric 
equation.  Give the regression equation and explain how to interpret the 
coefficients.  Suggested resource:  Angrist and Pischke textbook (pp. 210-
211), labor economics textbook, or www.wikipedia.org 

 

(9) Interaction terms:  Give the regression equation and explain how to 
interpret the coefficients when X variables include  x2 , x3 ,  and an 
interaction term (x2 x3).  Suggested resource:  econometrics textbook or 
www.wikipedia.org. 

 

(10) Dummy variable and interaction with dummy variable:  Give the 
regression equation and explain how to interpret the coefficients when X 
variables include a so-called dummy variable (D) and a dummy interaction (D 
x2).  Suggested resource:  econometrics textbook or www.wikipedia.org. 
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Concept Presenter 
(11) Omitted-variable bias formula:  Suppose a regression equation should 
have two X variables, but one X variable is mistakenly omitted during 
estimation.  How will the coefficient of the remaining X variable be affected?  
Give the formula and explain each part.  Give an example.  Suggested 
resource:   Angrist and Pischke textbook, econometrics textbook or 
www.wikipedia.org. 

 

(12) Heteroskedasticity:  Explain what it means for an error term in a 
regression equation to be heteroskedastic.  Are the least-squares estimates 
still unbiased?  Are the standard errors still valid?  Suggested resource:   
Angrist and Pischke textbook, econometrics textbook or www.wikipedia.org. 

 

(13) Four types of data sets:  Define cross-section, time-series, pooled, and 
panel (also called longitudinal) data sets.  Give examples and explain 
advantages of each type.  Suggested resource:  econometrics textbook or 
www.wikipedia.org. 
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RUBRIC FOR BACKGROUND BRIEFING 
 

Student name 
 

 

Concept presented 
 

 

Component Score Comments 
Motivation:  Why is this 
concept important or useful? 
 
 

/20  

Formal definition:  Use 
equations to define the 
concept. 
 

/20  

Graph, diagram, or other 
visual:  Illustrate the concept 
in a way that makes it easier 
to understand. 

/20  

Numerical example:  Given a 
sample numerical value for 
the concept, how would it be 
interpreted.  If possible, 
show a numerical example of 
how the value would be 
computed. 

/20  

References:  List at least two 
sources for further reading, if 
someone wants more detail.  
These might include pages in 
a textbook, a Wikipedia 
article, etc. 

/20  

Points deducted for spelling 
and grammatical errors 

  

TOTAL /100  
 
[end of assignment] 
 

Section A:  Writing Assignments Page A-3

ECON 190 - Seminar: Inequality © 2023  William M. Boal



 

TO:  ECON 190 Class 
FROM:  Bill Boal 
SUBJECT: Background briefing on “Law of Demand” 
DATE:  January 31, 2023 
 
Motivation:  Microeconomics is largely concerned with how prices are determined in markets.  In 
competitive markets, prices are determined by the interaction of buyers and sellers, each responding to 
the price by choosing an amount they wish to buy or sell.  How they respond to the price determines the 
equilibrium in the market. 
 
For buyers, the demand relation shows, for any given price, how much buyers wish to buy.  It can be 
represented by a schedule (or table), a function  QD=f(P),  or a curve on a graph (where conventionally 
price is on the vertical axis and quantity is on the horizontal axis). 
 
Formal definition:  The “Law of Demand” is the economic principle that the quantity of any good that 
buyers wish to buy is negatively related to its price, everything else equal.  Thus, the “Law of Demand” 
implies that a demand function, which shows the quantity demanded as a function of price, must have a 
negative derivative: 

𝑄 = 𝑓(𝑃),     
𝑑 𝑄

𝑑 𝑃
< 0    

 
Graph:  The “Law of Demand” implies that a demand curve must slope down. 

 
 
Numerical example:  The “Law of Demand” implies that on a demand schedule, the quantity demanded 
decreases as the price rises, as shown in the following example. 

Price Quantity demanded 
$2 900 units 
$3 700 units 
$4 600 units 
$5 550 units 

 
In the table above, as price increases from $3 to $4, the quantity demanded decreases from 700 units to 
600 units.  Over this range  ΔQD/ΔP = -100, a negative number. 
 
References: 
Law of Demand. (n.d.). Wikipedia.  Retrieved from https://en.wikipedia.org/wiki/Law_of_demand . 
Krugman, P. & Wells R. (2015).  Microeconomics. (4th ed.). New York, N.Y.: Worth Publishers. 
Cournot, A.A. (1838). Recherches sur les principes mathematiques de la theorie des richesses.  Paris: 
Hachette.  Chapter IV. 

Price 

Quantity 

Demand curve 
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ASSIGNMENT:  MIDTERM ESSAY 
 
Each student will write a midterm essay reflecting on the academic research we have read through Kaplan and Rauh 
(2013).  The essay should use and cite evidence presented in that research.  The length should be about 1000 to 1500 
words, plus bibliography. 
 
Question to be addressed:  Is wage inequality in the United States likely to continue to grow in the future?  First, 
summarize and synthesize the evidence in our readings.  What factors have caused the increase in wage inequality in 
the last fifty years?  Cover all the “explanations” in the syllabus.  Next, predict whether each of these factors will 
continue, stop, or perhaps reverse.  It is difficult to predict the future, but give your best guesses and defend them.  
Give reasons for your predictions, but acknowledge uncertainty as appropriate.  Finally, summarize your predictions 
to answer the question to be addressed. 
 
Audience:  Assume your readers know some economics and understand terms like "elasticity of substitution," "Gini 
coefficient," "human capital," and "standard error."   But assume your readers are not familiar with trends and 
explanations for wage inequality. 
 
Organization:  The top of the first page should contain the title (“Is Wage Inequality in the United States Likely to 
Grow in the Future?”), your name (no “by”), and the date.  The body may be divided into sections if desired.  An 
alphabetized bibliography formatted in APA style should appear on a separate page at the end.  Include and refer to 
one or more of the figures you created in Excel from data in the Census Bureau report, Income and Poverty in the 
United States. 
 
Writing style:  Academic economics is written in an impersonal, objective style.  Personal feelings do not belong.  
Uncertainty and conflicting evidence are recognized.  Suspicions and conjectures are acknowledged as such.  
Conclusions are never overstated.  As in natural science, use of the passive tense is perfectly acceptable. 
 
Citations and bibliography:  Citations in the text must use (author date) style.  Bibliography must be in APA 
format (see http://library.albany.edu/cfox).  Note that Monday readings in the syllabus are already listed in APA 
format, so for your bibliography, you can simply copy and paste. 
 
Writing Workshop:  Students must visit the Writing Workshop before submitting this essay.  Appointments are 
made at https://library.drake.edu/writing-workshop/ . 
 
Proofread your work:  Points will be deducted for spelling and grammatical errors, for deviation from APA style in 
citations and bibliography, for omitting page numbers, or for not using the Writing Workshop. 
 
Checkpoints: 
 

Due dates What 
Friday March 31 Schedule an appointment at the Writing Workshop.  Bring your 

essay and this assignment sheet.  Work with the Writing Tutor to 
ensure your essay tells a coherent story. 

Friday April 7 Submit midterm essay on Blackboard by 11:59 PM. 
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GRADING RUBRIC FOR MIDTERM ESSAY 

 

Student name 
 

 

Component Score Comments 
Does the paper show clear 
organization?  Can the reader 
discern the author’s outline 
and line of argument? 

/20  

Are all the factors that have 
caused the increase in wage 
inequality over the last fifty 
years clearly explained? 

/20  

Are sensible predictions 
offered for these factors in 
the future?  Are those 
predictions defended? 

/20  

Is the question in the title 
answered directly in a 
concluding paragraph? 

/20  

Is proper academic writing 
style observed, including 
author-date citations, APA-
style bibliography, topic 
sentences, objective tone, 
etc.? 

/20  

Points deducted for spelling 
and grammatical errors, 
omitting page numbers, or 
not visiting Writing 
Workshop. 

  

TOTAL /100  

 
 
[end of assignment] 
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ASSIGNMENT:  RESEARCH PAPER 
 
Each student will write an empirical research paper.  The paper should estimate a relationship or test a hypothesis 
using real data and econometric tools we discuss in class.  The paper need not be on “inequality”—it may be on any 
economic topic.  The idea need not be original—your paper can simply replicate an existing paper, perhaps with 
different data.  The length should be 2000 to 3000 words. 
 Getting started:  Think about what general topic interests you in the first few weeks of class.  Stop by 
during my office hours to chat.  I can suggest data sources and papers to check.  Allow plenty of time for finding and 
accessing data—this is often the most time-consuming part of any research project.  Think carefully about whether 
you are measuring a cause-and-effect relationship. 
 Organization:  Your paper must look professional and conform to formatting conventions of economic 
research, so that professionals in the field are more likely to read and understand it.  To make your job easier, a 
template in Microsoft Word has been posted on Blackboard.  All students must use the template and may deviate 
from it only with the instructor’s prior permission.  Be sure to delete all square brackets as you fill in your own 
material. 
 Writing style:  Academic economics is written in an impersonal, objective style.  Personal feelings do not 
belong.  Uncertainty and conflicting evidence are recognized.  Suspicions and conjectures are acknowledged as 
such.  Conclusions are never overstated.  As in natural science, use of the passive tense is perfectly acceptable. 
 Citations and bibliography:  Citations in the text must use (author date) style.  Bibliography must be in 
APA format (see http://library.albany.edu/cfox). 
 Writing Workshop:  You must consult the Writing Workshop before submitting your first draft.  
Appointments can be made at https://library.drake.edu/writing-workshop . 
 Proofread your work:  Points will be deducted for spelling and grammatical errors, for deviation from 
APA style in citations and bibliography, for not using the template provided on Blackboard, or for not using the 
Writing Workshop. 
 Oral presentations:  In late April, each student will make a 15-minute presentation to the class and 
Economics faculty members.  Prepare a PowerPoint presentation that summarizes your paper. Create at least one 
slide for each section of your paper and one slide for each table or graph.  Fonts should be at least 20 pt for 
readability. 
 
Deadline Checkpoint Length Points 
Friday Feb 17, 
11:59 PM. 

(1) Submit proposal, including research question and data 
description, on Blackboard. 

1 page 10 

Friday Mar 10, 
11:59 PM. 

(2) Submit draft data section and methodology section of research 
paper (use the template!) on Blackboard.  Also submit Stata log file 
showing how you computed descriptive statistics. 

3-5 pages 10 

By Friday Apr 14 Schedule appointment with Writing Workshop to discuss 1st draft of research paper.  Bring 
your entire paper and this assignment sheet.  Work with the Writing Tutor to ensure your paper 
tells a coherent story. 

Friday Apr 21, 
11:59 PM. 

(3) Submit 1st draft of research paper (use the template!) on 
Blackboard.  Also submit Stata log file showing how you computed 
the descriptive statistics and the estimates. 

2000 to 3000 
words 

20 

Apr 19-26 Oral presentations. 15 minutes  
Friday May 5, 
11:59 PM. 

(4) Submit final draft of research paper and Stata log file on 
Blackboard.  Also submit Stata log file showing how you computed 
the descriptive statistics and the estimates. 

2000 to 3000 
words 

60 

 
[end of assignment] 
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[TITLE OF PAPER] 
 

 

[Author] 

Drake University 

 

[Date] 

 

 

ABSTRACT:  [Give a summary of your paper in 100 to 200 words.  Briefly state your research 
question, your method, and your results.  Highlight in a sentence or two what is unique about 
your paper.  Provide enough information for someone to decide whether they want to read 
further, but maintain an objective and impersonal style.] 

 

KEYWORDS:  [Give 3-5 specific words or phrases that should lead a search engine to your 
paper.  Good examples:  returns to schooling, female labor-force participation, Islamic banking, 
rent control.  Bad examples:  schooling, participation, banking, housing, price, quantity, 
elasticity, cause, effect (too general).] 
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1. INTRODUCTION 
[What is the general topic and why is it interesting?  What research question(s) are you asking in 
this paper?  Foreshadow your method and results, but don’t give them all away.] 

 

2. LITERATURE REVIEW 
[What is already known about this question from economic theory and/or from previous 
empirical papers?  Find 3-5 previous papers using Google Scholar or using journal databases 
accessed through Cowles Library such as EBSCO, ECONLIT, or JSTOR.  (If you download a 
paper on your topic in the Journal of Economic Perspectives from www.aeaweb.org/journals/jep, 
subsequent papers that cited that paper will be listed at the very end of the PDF document.  This 
is a handy way to find the most recent published research on your topic.)   

You are not expected to completely understand the methodology of the papers you review.  Just 
give the main idea of each paper, which should be clear from reading the abstract, introduction, 
and conclusion. 

Do not merely list the papers.  Compare them to each other and tell a story about how previous 
research has tackled your question.  How will your approach differ from previous papers?  Cite 
all papers using APA’s author (date) style. 

In this and every section, the first paragraph should tell the reader where you are going, and the 
last paragraph should summarize key points and prepare the reader for the next section.] 

 

3. DATA 
[What data will you use to address your research question?  Where were the data obtained?  Who 
created the data?  Are the data well-suited to your research question?  Why?  Explain the 
structure of the data set.  Is it a cross-section, a time-series, or a panel?  What is the unit of 
observation:  a person, a county, a state, a country, etc., over a week, a month, a year, etc.?  How 
many observations are there?  Did you exclude any observations, and if so, why?  If you 
transformed any of the data, explain how and why.  Discuss your table of variable definitions and 
your table of descriptive statistics—see examples below.  Are the mean values and the ranges 
sensible?  If not, the reader will not take your analysis seriously.  Discuss any interesting features 
of the data.] 

 

4. METHODOLOGY 
[What equation are you estimating?  Write it out like this: 

ln(wage) = β1 + β2 schooling + β3 experience + β4 experience2 + error 

Identify the outcome (or dependent) variable, the treatment (or independent) variable, and the 
controls.  What functional form (logs, ratios, per-capita units, square terms, interactions, etc.) did 
you choose and why?  How does the equation bear on your research question? 
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Will the estimates have a causal interpretation, and if so, why?  In other words, what is your 
identification strategy (randomization, regression, instrumental variables, regression 
discontinuity, difference-in-differences, or something else)?  Is there a risk of omitted variable 
bias or selection bias?  If so, what controls have been omitted?] 

 

5. RESULTS 
[Give a table of coefficient estimates and include the standard error directly below each estimate 
in parentheses—see example below.  Discuss the values of the point estimates.  Do the signs and 
values of all the coefficients make sense?  Why or why not? 

Which coefficient estimate addresses your research question?  What is its sign and value?  Is it 
statistically significantly different from zero at 5%?  (Refer to p-value or t-statistic.  Remember 
that the R-square value is NOT a test statistic.)  If not, report a 95% percent confidence interval 
for it.  Remember that a low t-statistic can mean either that the coefficient is small or that the 
standard error is large.] 

 

6. CONCLUSIONS 
[What answers can you now give to the question(s) you posed in the introduction?  What 
questions remain unanswered?] 
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REFERENCES 
[The list of references must start on a new page.  References must include all papers cited in your 
paper and all data sources including websites, but nothing else (no “suggested readings.”)  List 
everything in APA format—see http://library.albany.edu/cfox for examples, and note that readings 
in our syllabus are listed in APA format.  References must be in alphabetical order of first 
author’s surname.  If first authors are the same, order papers by second author’s surname, etc.  If 
all authors are the same, list them chronologically by date of publication.] 
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FIGURE 1:  COAL FATALITIES PER THOUSAND COAL WORKERS 
 

 

 

SOURCES:  West Virginia—West Virginia Office of Miners' Health, Safety and Training, 
http://www.wvminesafety.org/historicprod.htm, accessed June 8, 2014.  United States—Mine Safety and 
Health Administration, http://arlweb.msha.gov/stats/centurystats/coalstats.asp, accessed March 8, 2016.  
West Virginia data are for fiscal years ending June 30 through 1924, and calendar years thereafter; data 
for 1925 cover 18 months. 

 

[Figures can help tell your story because they often communicate more clearly than the most 
carefully-written prose.  Figures and tables must start on a new page.  Note the difference 
between figures and tables:  figures are time plots, scatterplots, graphs, diagrams, and maps, 
while tables are arrays of words or numbers.  If your data are time series, you are REQUIRED to 
include a time plot of the dependent variable and most important independent variable(s).  If 
your methodology is difference-in-differences, you are REQUIRED to include a time plot of the 
dependent variable in “treated” and “control” groups so that the reader can check the “parallel-
trends” assumption.  If your dataset is small (under 100 observations) you are REQUIRED to 
include a scatterplot of the key dependent variable against the key independent variable.  In other 
cases, figures are recommended but not required. 

Figures can appear at the end of your paper, or they can be embedded in the narrative 
immediately after they are referenced for the first time, but not both.  If you choose to place your 
figures at the end of the paper, put each one on a separate page.  If you choose to embed your 
figures, be sure that each one starts on a new page.] 
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TABLE 1:  VARIABLE DEFINITIONS 
 

Variable Definition Formula 
Wage Average hourly earnings Earnings last week / hours 

worked last week 
Schooling Years of schooling completed  
Experience Years of potential labor-market 

experience 
Age – schooling - 6 

Union Member of a labor union 1=member, 0=nonmember 
 

SOURCE:  Current Population Survey, March 2009. 

 

[A table of variable definitions is required.  The above is an example.  Note that for readability, 
names of variables are plain English, not Stata variable names.  Note the formatting:  there are no 
vertical lines, and only two horizontal lines. 

Tables can appear at the end of your paper, or they can be embedded in the narrative 
immediately after they are referenced for the first time, but not both.  If you choose to place your 
tables at the end of the paper, put each one on a separate page.  If you choose to embed your 
tables, be sure that each one starts on a new page and does not break across pages—in MS Word, 
choose Paragraph>Line and page breaks>Keep with next.  Every table must be discussed, at 
least briefly, in your text, but include enough notes to the table that it can be understood without 
reading the text.] 
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TABLE 2:  DESCRIPTIVE STATISTICS 
 

 Number of 
observations 

Mean Standard 
deviation 

Minimum Maximum 

Wage 953 20.57 4.65 5.50 88.75 
Schooling 952 13.72 1.75 8.00 20.00 
Experience 952 15.38 3.95 2.00 52.00 
Union 921 0.092 0.289 0.00 1.00 

 

SOURCE:  Current Population Survey, March 2009.  Accessed at ipums.org, February 2011. 

 

[A table of descriptive statistics is required.  All statistics necessary for this table can be 
computed by the Stata command summarize , but do not simply paste Stata output into your 
paper.  Instead, use the more professional format shown above.  The purpose of this table is to 
help the reader understand your estimates in the next table, so compute the numbers for this table 
after you have dropped unusable observations.  For readability, names of variables should be 
plain English, not Stata variable names.  Show all digits for whole numbers and at least three 
significant digits for fractions.  Note the formatting:  there are no vertical lines, and only two 
horizontal lines.  You can add columns for additional statistics, such as the median (computed 
with  summarize  option  detail), if they help the reader understand the data better.] 
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TABLE 3:  ESTIMATES OF THE EFFECT OF SCHOOLING ON LOG 
HOURLY WAGE 

 (1) (2) (3) 
Schooling 0.127 

(0.304) 
0.143 

(0.272) 
0.133 

(0.265) 
    
Experience  0.012 

(0.002) 
0.011 

(0.002) 
    
Experience, squared  -0.0006 

(0.002) 
-0.0005 
(0.002) 

    
Union member   0.143 

(0.062) 
    
Adjusted R-square 0.038 0.044 0.047 
Number of observations 952 952 921 

 

NOTES:  Dependent variable is log hourly wage.  Standard errors robust to heteroskedasticity 
are shown in parentheses. 

 

[A table of estimates is required.  Do not simply paste Stata output into your paper.  Instead, use 
the more professional format shown above.  Note that for readability, names of variables are 
plain English, not Stata variable names.  Note the formatting:  there are no vertical lines, and 
only two horizontal lines.  Standard errors must be in parentheses, so they are easy to distinguish 
from coefficient estimates, and notes at the bottom should describe how those standard errors 
were computed.  Show three decimal places after the decimal point—more if the number would 
otherwise show as zero.  Show at least three columns of alternative estimates to illustrate how 
robust your results are to alternative equation specifications.  Add more regressors (X variables) 
as you move from left to right.  If you have more rows of estimates than can fit on the page, and 
some of the coefficients are not important to your story, don’t display unimportant coefficients in 
the table, but say in the notes “Control variables include …”  If you have more columns than can 
fit on the page, create another table.] 
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DATA APPENDIX 
 

[A data appendix is required.  It should start on a new page.  The purpose of a data appendix is to 
document your data well enough that another economist could find the same data and replicate 
your results.  So your data appendix must give a detailed explanation of how you obtained the 
data, including any websites and dates accessed.  It should also describe which observations you 
deliberately dropped from the analysis and why (for example, data were incomplete, data seemed 
to contain errors, etc.) and how you transformed the data.  Finally, describe the software (Stata, 
Excel, etc.) used to make the calculations.  In the case of Stata, indicate which commands were 
used to compute the estimates (regress, ivregress, xtreg, xtivreg, etc.)  If you 
include tables in your appendix, number them A1, A2, etc., and use the same formatting as 
regular tables.  End your appendix with the following sentence.] 

Data and Stata code used to compute the estimates are available from the author on 
request. 

[And mean it!  Keep a copy of your data file and your Stata do-file.] 
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GRADING RUBRIC 
RESEARCH PAPER CHECKPOINT 1 

PROPOSAL 
 
 

Student name 
 

 

Component Score Comments 
RESEARCH QUESTION:  
What is your research 
question?  Are you trying 
to estimate a causal 
relationship? 

/3  

DATA:  What is the source 
of your data?  Are the data 
cross-section, time series, 
panel, or pooled?  What is 
the unit of observation?  
What is the outcome 
variable?  What is the 
treatment variable(s)? 

/7  

OVERALL /10  

 
[end of rubric] 

Section A:  Writing Assignments Page A-17

ECON 190 - Seminar: Inequality © 2023  William M. Boal



ECON 190 – Seminar:  Inequality  
Drake University, Spring 2023 
William M. Boal  

 

 

GRADING RUBRIC 
RESEARCH PAPER CHECKPOINT 2 

DATA AND METHODOLOGY SECTIONS 
 

Student name 
 

 

Component Score Comments 
DATA SECTION TEMPLATE:  What 
data will you use to address your 
research question?  Where were the data 
obtained?  Who created the data?  Are 
the data well-suited to your research 
question?  Why?  Explain the structure of 
the data set.  Is it a cross-section, a time-
series, or a panel?  What is the unit of 
observation:  a person, a county, a state, 
a country, etc., over a week, a month, a 
year, etc.?  How many observations are 
there?  Did you exclude any 
observations, and if so, why?  If you 
transformed any of the data, explain how 
and why.  Discuss your table of variable 
definitions and your table of descriptive 
statistics—see examples below.  Are the 
mean values and the ranges sensible?  If 
not, the reader will not take your analysis 
seriously.  Discuss any interesting 
features of the data. 

/4  

METHODOLOGY SECTION 
TEMPLATE:  What equation are you 
estimating?  Write it out like this: 

ln(wage) = β1 + β2 schooling + β3 
experience + β4 experience2 + error 

Identify the outcome (or dependent) 
variable, the treatment (or independent) 
variable, and the controls.  What 
functional form (logs, ratios, per-capita 
units, square terms, interactions, etc.) did 
you choose and why?  How does the 
equation bear on your research question? 

Will the estimates have a causal 
interpretation, and if so, why?  In other 
words, what is your identification 
strategy (randomization, regression, 
instrumental variables, regression 
discontinuity, difference-in-differences, 
or something else)?  Is there a risk of 
omitted variable bias or selection bias?  
If so, what controls have been omitted? 

/4  

Table of variable definitions /1  

Table of descriptive statistics /1  

Points deducted for spelling or 
grammatical errors, for not following 
template, or for skipping class workshop 

  

TOTAL /10  
 

[end of rubric] 
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GRADING RUBRIC 
RESEARCH PAPER CHECKPOINT 3 

FIRST DRAFT 
 
See template posted on Blackboard for expected contents of each section. 
 

Student name 
 

 

Component Score Comments 
Section 1:  Introduction /3  

Section 2: Literature 
review 

/3  

Section 3:  Data /3  

Section 4:  Methodology /3  

Section 5:  Results /3  

Section 6:  Conclusions /3  

Format:  title page, 
abstract, keywords, 
references, tables, figures, 
data appendix, and page 
numbers. 

/2  

Points deducted for spelling or 
grammatical errors, for deviation 
from APA style in citations and 
bibliography, for not using the 
template provided on 
Blackboard, for not using 
Writing Workshop, for skipping 
class workshop, or for not 
supplying Stata log file. 

  

OVERALL /20  

 
[end of rubric] 
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SECTION B 
STATA LAB 

INSTRUCTIONS 
 
  



 
William M. Boal  January 2023 

 
 

Frequently-Used Stata Commands 

The general form for a Stata command is 

 [prefix:]  command  [in …] [if …]  [, options] 

The following commands are frequently used in Stata  .do  files.  Most commands can be abbreviated.  
For detailed information and examples, in Stata, choose  Help>Stata command…   

Command What it does 
* blah Comment at beginning of line, not executed by Stata. 
command  // blah Comment at end of line, not executed by Stata. 
command  /// Continue command onto next line. 
log Create a file of results for all commands that follow. 
clear Remove existing data from memory. 
infile  Read data in free format (separated by spaces in a text file). 
import Read data from a spreadsheet. 
use Read data from a file already in Stata format (.dta). 
describe List variables in the data set and their labels. 
summarize Compute descriptive statistics. 
tabulate Tabulate a variable or cross-tabulate several variables that each take a limited 

number of different values. 
histogram Draw a histogram for a variable. 
list Peek at the data by listing a specified number of observations of specified 

variables. 
label Attach an explanatory label to a variable, or to particular values of a variable. 
generate Compute a new variable from existing ones. 
replace Modify values of an existing variable. 
drop Delete specified unneeded variables or observations (helpful when working 

with very large data sets). 
keep Keep only specified variables or observations. 
sort Sort the observations on one or more variables. 
egen Compute a new variable using multiple observations of existing variables. 
destring Convert alphabetical values to numerical values. 
ttest Test whether two subsamples have identical means. 
regress Estimate ordinary least-squares regression. 
ivregress Estimate instrumental-variables regression. 
test Immediately following a regression command (“postestimation”), test the 

hypothesis that one or more coefficients are zero. 
log close Close file of results. 
exit End of Stata do file. 

 
Also see Help>Stata command…>operators   to see how to write expressions like   “variable 1 divided by 
variable 2” or “variable 1 greater than variable 2”. 
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Tips for Using Stata Efficiently 

(1) While using Stata, close any other applications and windows that you don't need. 

(2) File extensions ( .xyz) indicate what kind of file it is.  Working with Stata is easier if you can see file 
extensions.  For example, when downloading a data extract from IPUMS, you will get a group of files:  a 
compressed data file, a Stata do-file, a codebook file, and so forth.  All files in the same IPUMS extract 
will have the same name, but different file extensions ( .dat.gz, .do, .cbk, etc.). 

 On a Windows computer, in File Manager, choose View tab and check the box for file name 
extensions. 

 On a Mac computer, in Finder, choose Preferences>Advanced>Show all filename extensions. 

(3) Keep all your files for a project in one folder.  After you start Stata, choose File>Change working 
directory… to point Stata at that folder. 

(4) For any complicated work in Stata, create a do-file of your Stata commands so you can easily 
replicate or revise your work later if needed. 

(5) Make sure your do-file creates a log file of results, preferably in text format that can be read without 
Stata. 

(6) Sprinkle comments throughout your do-file, so that (a) you can come back to it later and remember 
what you were doing and (b) someone else, such as your professor or your classmate, can understand 
your code.  In Stata, * at the beginning of a line indicates that the entire line is a comment, and // in the 
middle of a line indicates that the remainder of the line is a comment. 

(7) When you exit Stata, it will ask you whether you want to save your data.  In most cases you should 
just say no!  If you save the data, then any variables you “generated” will be added to the Stata dataset, 
and the next time you run your Stata do-file, you will get an error message.  This is because Stata will not 
allow you to “generate” a variable that already exists. 
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 Topics:  Downloading IPUMS data 

 

National Health Interview Survey Lab 
Part 1 of 4:  Extract NHIS data from IPUMS 

IPUMS, a service located at the University of Minnesota, houses and organizes large samples of person-
level and household-level data, including the National Health Interview Survey (NHIS).  Anyone can 
access (“extract”) the data free from IPUMS, though you must register.  Let’s extract some data. 

1. If you are still viewing your extract page, refresh it.  If you are logged out of IPUMS, go to 
www.ipums.org , choose “IPUMS Health Surveys” and then “NHIS-Get Data” to access data from the 
National Health Interview Survey.  Choose “Create an extract—get data.” 

2. The NHIS collects both household-level data (H) and person-level data (P).  Both kinds of variables 
are organized in categories.  We will extract “person” variables needed to replicate table 1.1 in the 
book by Angrist and Pischke.  Under “Select Variables/Person” add the following variables to your 
cart. 

o Category:  Person>Demographic>Core Demographic .  Add the variables AGE, SEX, and 
MARSTAT to your cart by clicking on the plus (+) signs. 

o Category:  Person>Demographic>Ethnicity/Nativity .  Add the variable RACENEW to your 
cart. 

o Category:  Person>Demographic>Family interrelationships .  Add the variable FAMKIDNO to 
your cart. 

o Category:  Person>Socio-Economic Status>Education .  Add the variable MAXEDUC to your 
cart. 

o Category:  Person>Socio-Economic Status>Work .  Add the variable EMPSTAT to your cart. 
o Category:  Person>General Health>General Health .  Add the variable HEALTH to your cart. 
o Category:  Person>Health Insurance>General Coverage .  Add the variable HINOTCOVE to 

your cart. 

3. Choose “Select Samples.”  Let’s use only the latest available year. 
o Check only the box for 2021. 
o Click on “Submit Sample Selections.” 

4. View your data cart.  You should have a number of “preselected” variables (YEAR through 
CSTATFLG) and the above variables selected by you (AGE through HINOTCOVE). 

5. Choose “Create Data Extract.”  In the box labeled “Describe your extract,” type something that will 
help you remember why you created this extract—for example “ECON 190 NHIS LAB EXERCISE.” 
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6. Choose “Submit Extract.”  You will be asked to sign in with your email address and password.  If you 
do not already have an account at IPUMS, you will be asked to create one and to agree to the terms 
of use. 

7. You have now requested data for only one year.  So is your extract a cross section, a time-series, a 
pooled dataset, or a panel (or longitudinal dataset)?  _____________________________________ 
If you had checked boxes for several years, what kind of dataset would you get? _______________ 
________________________________________________________________________________ 

8. Log out of IPUMS. 
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 Stata commands:  summarize 

 

National Health Interview Survey Lab 
Part 2 of 4:  Open IPUMS-NHIS data in Stata 

Let’s save and view the data we extracted from IPUMS-CPS.   

1. Go to www.ipums.org , choose “IPUMS Health Surveys” and then “NHIS-Get Data” to access data 
from the National Health Interview Survey.  Choose “Create an extract—get data.”  Log into your 
account.  Then choose “MY DATA.” 

2. You will see that IPUMS has created several files for you for download.  Create a folder on your 
computer for this lab.  Then save the following files to your computer in that folder.  (In Windows, 
right-click and choose “Save link as...”) 

o Download DAT:  This is a large fixed-width text file of the data you requested, in compressed 
( .dat.gz) format to speed downloading. 

o Stata:  This do-file ( .do) will read the data file. 
o Basic Codebook.  This codebook-file ( .cbk) contains short descriptions of each variable you 

requested.  You can read it with a text editor (such as Windows Notepad or MacOS TextEdit) 
or with MS-Word. 

o DDI Codebook.  This file contains more detailed descriptions of each variable, but do not 
download it as is.  Instead, click on the link to view it and then print or save it as a PDF file. 

After downloading the four files, log out of IPUMS. 

3. All your IPUMS files have the same file name but different file extensions ( .something).  Set your 
computer so that you can see file extensions.   

o Mac users:  In the Finder>Preferences menu, select the Advanced tab and check the box 
“Show all filename extensions.” 

o Windows users:  In the File Manager window, select the View tab and check the box “File 
name extensions.” 

4. You must decompress your data file ( .dat.gz) before Stata can read it. 
o Mac users:  You should be able to decompress the file by double-clicking on it. 
o Windows users:  You will need special software to decompress the file:  7-Zip (free, open 

source) is recommended.  It runs under Windows 10, 8, or 7 and there are versions for 32-
bit and 64-bit machines.  Get it at 7-zip.org .  After you run the installation file, decompress 
the  dat.gz  file by right-clicking on it and choosing  7-Zip>Extract here. 

5. Launch Stata.  Then choose File>Change working directory…  to point Stata at the folder where your 
downloaded files are located. 
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6. The do-file (.do) provided by IPUMS is a series of Stata commands to read the data.  Edit the do-file 
by choosing Window>Do-file Editor>New Do-file Editor .  When the Do-file Editor window opens, 
choose File>Open to access the do-file provided by IPUMS.  You will see that this do-file contains 
many commands that tell Stata how to interpret the data in the raw data file (.dat) that you just 
decompressed. 

7. At the end of the do-file, add the following command: 

summarize 

Choose Tools>Execute (do) or click on the corresponding button to run your do-file. 

8. Look at the summary statistics generated by the “summarize” command in your results window.  
You should have over 72,000 observations. 

o Why is the standard deviation of  YEAR  equal to zero? ___________________________ 
o What is the average  AGE  in your sample? ____________________________________ 
o What is the average  FAMKIDNO  in your sample? _________________________________ 

The other variables are difficult to interpret without consulting the codebooks. 

9. Save your do-file.  In the Do-file Editor window, choose File>Save as…  and give it a sensible name. 

10. The data are now in memory but need to be saved to a file.  Save the data in Stata’s own proprietary 
.dta  format, which includes the auxiliary information provided by IPUMS in the  do-file.  In the big 
window, choose File>Save as…  and give it a sensible name.  In what follows, I will assume you gave 
it the name  nhislabdata . 
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 Stata commands:  summarize 

 

National Health Interview Survey Lab 
Part 3 of 4:  Interpret data values using codebook 

At first glance, the values of the some of the variables in our extract do not make sense.  That is because 
people give a variety of verbal answers to the NHIS, all of which are coded as numbers even if their 
answer was not a number.  The way those answers are coded can be confusing, but the codebooks can 
help us. 

1. Launch Stata.  Then choose File>Change working directory…  to point Stata at the folder where your 
do-file (.do) and Stata data file (.dta) are located. 

2. Choose Window>Do-file Editor>New Do-file Editor .  When the new window opens, choose 
File>Open to access the do-file you saved in the last lab.  Choose Tools>Execute (do) or click on the 
corresponding button to run your  do-file. 

3. Look at the summary statistics generated by the  summarize  command in your results window.  
Simultaneously, open one of the codebook files. 

4. In the codebook file, scroll down to the documentation for SEX.  What does it mean if the variable  
SEX=1?  If  SEX = 2?   ______________________________________________________________ 
According to the summary statistics, what fraction of the sample is female?  What fraction is male? 
_______________________________________________________________________________ 

5. What does it mean if the variable  RACENEW=100?  If  RACENEW = 400? 
_______________________________________________________________________________ 

6. What does it mean if the variable  MAXEDUC=0?  If  MAXEDUC=08?  If  MAXEDUC=11?  
_______________________________________________________________________________ 

7. What values of  EMPSTAT  indicate the person is currently working?  
_______________________________________________________________________________ 

8. What value of  HEALTH  indicates excellent health? _____________________________________ 
What value indicates poor health? __________________________________________________ 
What values indicate that the health status question was not asked, or that the respondent did not 
answer? ______________________________________________________________________ 
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 Stata commands:  log, use, 
describe, summarize, generate, 

replace, ttest, exit 

 

National Health Interview Survey Lab 
Part 4 of 4:  Replicate table 1.1 in Angrist and Pischke 

Table 1.1 in Angrist and Pischke (p. 5) compares health status and other variables for people with and 
without health insurance.  Let’s write a Stata do-file to compute similar numbers with our data.  Our 
numbers may differ from Angrist and Pischke’s for at least four reasons.  First, Angrist and Pischke’s 
table 1.1 uses data from 2008, whereas our data are from 2020.  Second, table 1.1 uses data on 
husbands and wives, so that the number of females is exactly equal to the number of males in their 
data—as we saw in the previous part, that is not quite true for our data.  Third, we did not collect data 
on family income.  Respondents in the NHIS report their income in broad categories (zero to $35 
thousand, $35 thousand to $50 thousand, etc.).  Angrist and Pischke use these categories to impute 
numerical family income using an elaborate procedure (see pp. 249-250) which we will skip.  Finally, the 
NHIS is not a representative sample, so sampling weights must be applied to estimate values for the U.S. 
population as a whole.  Angrist and Pischke apply these weights, but we will skip them. 

1. Now let’s write a Stata do-file to compute our numbers.  In Stata, choose Window>Do-file 
Editor>New Do-file Editor .  Every do-file should begin with the following:  one or more  “*”  
comments to explain the purpose of the do-file, a  log  command  to direct all Stata calculations to 
a file, a command to open a dataset and clean out any prior data from memory, and commands to 
check the dataset.  So type the following lines into the blank window: 

* Program to analyze NHIS 

* log using log file name, text replace 
use nhislabdata.dta, clear 
describe 
summarize 
tab1 hinotcove 
 

The log file name should be the same name you plan to give this do-file. 

2. In the previous part of this lab, we found that some values of the variables actually indicate that the 
data are missing.  We need to exclude any observations with missing data.  There are many ways to 
do this.  I like to generate a special zero-one variable, which I call  ok2use,  to flag useable 
observations as follows: 

generate ok2use = age>=26 & age<=59 /// 
  & sex<7 /// 
  & famkidno<98 /// 
  & racenew<900 /// 
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  & maxeduc>0 & maxeduc<96 /// 
  & empstat>0 & empstat<900 /// 
  & health<7 /// 
  & hinotcove>0 & hinotcove<7  
 

3. Next, referring to the codebook, we need to create variables that match (at least approximately) the 
variables in Angrist and Pischke’s table 1.1.  We use the following important Stata commands.   

o The  generate  command creates a new variable for the first time.   
o The  replace  command modifies the values of an existing variable.   
o The  if  clause at the end of each command restricts the command to certain observations.   

Type the following lines. 

generate insured = 1 if hinotcove==1     // has health insurance 
  replace insured = 0 if hinotcove==2    // no health insurance 
generate healthindex = 6 – health        // 5=excellent, 1=poor 
generate nonwhite = racenew>100 
generate hsdiploma = maxeduc>2           // has HS diploma 
generate bachelors = maxeduc>7           // has bachelors degree 
generate employed = 1 if empstat>=100 & empstat<200 
  replace employed = 0 if empstat>=200 & empstat<900 
 

Note that everything following  //  is a comment.  It is good practice to sprinkle comments 
everywhere to make your Stata code easier to read. 

4. Now let’s compute the numbers corresponding to table 1.1.  Starting at the top left of the table, 
compute the mean health status of men with and without health insurance, the difference in the 
means, and the standard errors.  This can be done with a single  ttest  command, which tests for a 
difference in the means of two samples: 

ttest healthindex if ok2use & sex==1, by(insured)  // men 
 

5. Finally, end your do-file with the following commands.  The  clear  command deletes data from 
memory, avoiding problems the next time the do-file is run.  The  log close  command stops 
writing output to the log file and releases the log file to other applications. 

clear 
* log close 
 

6. Choose Tools>Execute (do) or click on the corresponding button to run your do-file. 

  

Section B:  Stata Lab Instructions Page B-9

ECON 190 - Seminar: Inequality © 2023  William M. Boal



7. Look at the output from  ttest  in the Stata output window. 
What is the average value of health status for men with insurance? _______________________ 
What is the average value for men without insurance? _________________________________ 
Is the difference statistically significant? _____________ Why or why not? _________________ 
 
______________________________________________________________________________ 
Are the estimates computed by  ttest  similar to the corresponding numbers in Angrist and 
Pischke’s table 1.1?  Comment. 
_______________________________________________________________________________ 
_______________________________________________________________________________ 

8. Now insert additional  ttest  commands to compare the health status of women with and without 
health insurance.  Then insert additional  ttest  commands to compare other variables 
(nonwhite, hsdiploma, bachelors, employed) for men and women with and without 
health insurance.  Run your do-file again and compare the results to the corresponding numbers in 
Angrist and Pischke’s table 1.1.  
_______________________________________________________________________________ 
_______________________________________________________________________________ 
_______________________________________________________________________________ 

9. If everything looks good, erase the stars in front of the commands log using... and log close   
and run the do-file one more time to create a log file of your output.  Save your do-file, giving it the 
same name as log file name above (it will be assigned a different extension).  Upload your log-file to 
Blackboard. 

10. When exiting Stata, do NOT save your data.  Saving your data in memory sounds like a good idea, 
but it is not and here is why.  Your data in memory now includes a slew of new variables, including   
insured, healthindex, nonwhite, etc.  If you save your data in memory, all these 
variables will be added to your  .dta  file.  But then you will get errors the next time you run your do-
file, because one cannot “generate” a variable that already exists in the  .dta  file. 

 

[end of lab] 
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 Topics:  Downloading CPS data 

 

Current Population Survey Lab 
Part 1 of 5:  Extract CPS data from IPUMS 

IPUMS, a service located at the University of Minnesota, houses and organizes large samples of person-
level and household-level data, including the Current Population Survey (CPS).  Anyone can access 
(“extract”) the data free from IPUMS, though you must register.  Let’s extract some data. 

1. Go to www.ipums.org .  Choose “IPUMS CPS” to access data from the Current Population Survey. 

2. Choose “Create an extract—get data.” 

3. The CPS collects both household-level data (H) and person-level data (P).  Both kinds of variables are 
organized in categories.  We will extract “person” variables needed to estimate a Mincer wage 
equation.  Under “Select Variables/Person” add the following variables to your cart. 

o Category:  Person>Core>Demographics .  Add the variables AGE, SEX, and RACE to your cart 
by clicking on the plus (+) signs. 

o Category:  Person>Core>Work .  Add the variable EMPSTAT to your cart. 
o Category:  Person>Core>Education .  Add the variable EDUC to your cart. 
o Category:  Person>Annual Social and Economic Supplement (ASEC)>Work .  Add the 

variables WORKLY, WKSWORK1 and UHRSWORKLY.  (Note that variables in this group are 
only available in the ASEC.) 

o Category:  Person> Annual Social and Economic Supplement (ASEC)>Income .  Add the 
variable INCWAGE.  (Note that variables in this group are only available in the ASEC.) 

4. Choose “Select Samples.”  We will collect just one sample to keep the exercise simple and minimize 
the file size. 

o Under the ASEC tab, check only the box for ASEC 2022—uncheck everything else, including 
the samples under “BASIC MONTHLY.”  The easy way to uncheck everything is to uncheck 
“All Default Samples” at the top. 

o Uncheck everything under the BASIC MONTHLY tab also. 
o Click on “Submit Sample Selections.” 

5. View your data cart.  You should have a number of “preselected” variables (YEAR through ASECWT), 
the above variables selected by you (AGE through INCWAGE), and one sample (ASEC 2022). 

6. Choose “Create Data Extract.”  In the box labeled “Describe your extract,” type something that will 
help you remember why you created this extract—for example “ECON 190 CPS lab exercise.” 
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7. Choose “Submit Extract.”  You will be asked to sign in with your email address and password.  If you 
do not already have an account at IPUMS, you will be asked to create one and to agree to the terms 
of use. 

8. You have now requested data for only one year.  So is your extract a cross section, a time-series, a 
pooled dataset, or a panel (or longitudinal dataset)?  _____________________________________ 
If you had checked boxes for several years, what kind of dataset would you get? _______________ 
________________________________________________________________________________ 

9. Log out of IPUMS. 
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 Stata commands:  summarize 

 

Current Population Survey Lab 
Part 2 of 5:  Open IPUMS-CPS data in Stata 

Let’s save and view the data we extracted from IPUMS-CPS. 

1. If you are still viewing your extract page, refresh it.  If you are logged out of IPUMS, go to 
www.ipums.org , choose “IPUMS CPS” and then “CPS-Get Data” to access data from the Current 
Population Survey.  Choose “Create an extract—get data.”  Log into your account.  Then choose “MY 
DATA.” 

2. You will see that IPUMS has created several files for you for download.  Create a folder on your 
computer for this lab.  Then save the following files to your computer in that folder.  (In Windows, 
right-click and choose “Save link as...”) 

o Download DAT:  This is a large fixed-width text file of the data you requested, in compressed 
( .dat.gz) format to speed downloading. 

o STATA:  This do-file ( .do) will read the data file. 
o Basic Codebook.  This codebook-file ( .cbk) contains short descriptions of each variable you 

requested.  You can read it with a text editor (such as Windows Notepad or MacOS TextEdit) 
or with MS-Word. 

o DDI Codebook.  This file contains more detailed descriptions of each variable, but do not 
download it as is.  Instead, click on the link to view it and then print or save it as a PDF file. 

After downloading the four files, log out of IPUMS. 

3. All your IPUMS files have the same file name but different file extensions ( .something).  Set your 
computer so that you can see file extensions. 

o Mac users:  In the Finder>Preferences menu, select the Advanced tab and check the box 
“Show all filename extensions.” 

o Windows users:  In the File Manager window, select the View tab and check the box “File 
name extensions.” 

4. You must decompress your data file ( .dat.gz) before Stata can read it. 
o Mac users:  You should be able to decompress the file by double-clicking on it. 
o Windows users:  You will need special software to decompress the file:  7-Zip (free, open 

source) is recommended.  It runs under Windows 10, 8, or 7 and there are versions for 32-
bit and 64-bit machines.  Get it at 7-zip.org .  After you run the installation file, decompress 
the  dat.gz  file by right-clicking on it and choosing  7-Zip>Extract here. 
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5. Launch Stata.  Then choose File>Change working directory…  to point Stata at the folder where your 
downloaded files are located. 

6. The do-file (.do) is a series of Stata commands to read the data.  Edit the do-file by choosing 
Window>Do-file Editor>New Do-file Editor .  When the Do-file Editor window opens, choose 
File>Open to access the do-file provided by IPUMS.  You will see that this do-file contains many 
commands that tell Stata how to interpret the data in the raw data file (.dat) that you just 
decompressed. 

7. At the end of the do-file, add the following command: 

summarize 

Choose Tools>Execute (do) or click on the corresponding button to run your do-file. 

8. Look at the summary statistics generated by the “summarize” command in your results window.  
You should have over 150,000 observations. 

o Why is the standard deviation of  YEAR  equal to zero? ___________________________ 
o What is the average  AGE  in your sample? ____________________________________ 
o What is the smallest  AGE ? ________________________________________________ 
o What is the largest? ______________________________________________________ 

The other variables are difficult to interpret without consulting the codebooks. 

9. Save your do-file.  In the Do-file Editor window, choose File>Save as…  and give it a sensible name. 

10. The data are now in memory but need to be saved to a file.  Save the data in Stata’s own  .dta  
format, which includes the auxiliary information provided by IPUMS in the  do-file.  In the big 
window, choose File>Save as…  and give it a sensible name.  In what follows, I will assume you gave 
it the name  cpslabdata . 
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 Stata commands:  summarize 

 

Current Population Survey Lab 
Part 3 of 5:  Interpret data values using codebook 

At first glance, the values of the some of the variables in our extract do not make sense.  That is because 
people give a variety of verbal answers to the CPS, all of which are coded as numbers even if their 
answer was not a number.  The way those answers are coded can be confusing, but the codebooks can 
help us. 

1. Launch Stata.  Then choose File>Change working directory…  to point Stata at the folder where your 
do-file (.do) and Stata data file (.dta) are located. 

2. Choose Window>Do-file Editor>New Do-file Editor .  When the new window opens, choose 
File>Open to access the do-file you saved in the last lab.  Choose Tools>Execute (do) or click on the 
corresponding button to run your  do-file. 

3. Look at the summary statistics generated by the  summarize  command in your results window.  
Simultaneously, open one of the codebook files. 

4. In the codebook file, scroll down to the documentation for SEX.  What does it mean if the variable  
SEX=1?  If  SEX = 2?   ______________________________________________________________ 

According to the summary statistics, what fraction of the sample is female?  What fraction is male? 
_______________________________________________________________________________ 

5. What does it mean if the variable  RACE=100?  If  RACE = 830? 
___________________________________________________________________ 

6. What value of  EMPSTAT  indicates the person is currently working?  What value indicates the 
person has a job but was not at work last week? 
___________________________________________________________________ 

7. What does it mean if the variable  EDUC=125?  What value of  EDUC  indicates a high school diploma 
but no more schooling? 
___________________________________________________________________ 

8. What does it mean if the variable  UHRSWORKLY=999? 
___________________________________________________________________ 
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 Stata commands:  log, use, 
tabulate, describe, generate, 

replace, recode, exit 

 

Current Population Survey Lab 
Part 4 of 5:  Calculate years of schooling in the CPS 

There is no variable in the CPS that represents years of schooling.  How can we compute one? 

1. Open one of the codebook files and look for the documentation on “EDUC.”  There are about 36 
possible values of EDUC!  Fortunately, not all of these values appear in the sample that we have 
downloaded. 

2. Let’s see how many different values we actually have in our sample.  Launch Stata.  Then choose 
File>Change working directory…  to point Stata at the folder where your files are located.  Choose 
Window>Do-file Editor>New Do-file Editor .  When the new window opens, choose File>Open to 
access the do-file you saved in the last lab.  At the end of the  do-file, below the “summarize” 
command, add the following commands: 

tabulate educ 
tabulate educ, nolabel 

Choose Tools>Execute (do) or click on the corresponding button to run your  do-file.  Now check the 
results window.  It appears there are about 17 possible values of EDUC in our sample.  We need to 
translate only those values into years of schooling.  Use the output in Stata’s results window to 
complete the following table. 

Value of  Schooling Value(s) of  EDUC 
Missing 1 

0 2 
4 10 
6 20 
8 30 
9 40 

10  
11  
12 71  or  73 
13  
14 or 
16  
18  
19  
20  

  

Section B:  Stata Lab Instructions Page B-16

ECON 190 - Seminar: Inequality © 2023  William M. Boal



3. Now let’s write Stata code to implement this table.  In Stata, choose Window>Do-file Editor>New 
Do-file Editor .  When the new window opens, type the following lines into the blank window: 

* Program to analyze CPS-ASEC 
* log using log file name, text replace 
use cpslabdata.dta, clear 
describe 
summarize 
tabulate  educ 

 
“Log file name” can be any name you want, but to minimize confusion, use the same name that you 
plan to give this do-file.  In what follows, I will assume you chose the name  myprog . 
 
We will now create a new variable  schooling from the CPS variable  educ.  There are at least 
two ways to do this.  The first way uses the  replace  command repeatedly: 

generate  schooling = . 
replace  schooling = 0 if educ==2 
replace  schooling = 4 if educ==10 
etc. 
replace  schooling = 12 if  educ== 71 | educ== 73 
etc. 

Recall that the vertical bar means “or”.  The second way uses the  recode  command just once, but 
the command is so long that it spills over multiple lines.  Be sure to add three slashes whenever you 
continue to the next line: 

recode educ  2=0  10=4  etc.  71 73=12  etc.   /// 
  , generate(schooling) 

Choose whichever method you like and finish your program with the following commands 
tabulate  schooling 
clear 
* log close 
 

4. How are your Stata skills?  Do you know what each command above does?  You can look up any of 
them by choosing Help>Stata command… 

5. Choose Tools>Execute (do) or click on the corresponding button to run your do-file.  Now check the 
results window.  Does the tabulation for the variable “schooling” make sense? 

6. If all is well, in the Do-file Editor window, choose File>Save as…  and give it the same name as the log 
file name above (it will be assigned a different extension). 
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 Stata commands:  histogram, regress 

 

Current Population Survey Lab 
Part 5 of 5:  Estimate a Mincer wage equation 

A Mincer wage equation relates a person’s log wage (lwage) to schooling and labor-market experience 
(exper) as follows: 

lwage  =  β1  +  β1 schooling  +  β3 exper  +  β4 exper2 , 

Let’s estimate a Mincer equation on your data extract, using the measure of schooling that you 
calculated in the last lab. 

1. Launch Stata.  Then choose File>Change working directory…  to point Stata at the folder where your 
files are located.  Choose Window>Do-file Editor>New Do-file Editor .  When the new window opens, 
choose File>Open to access the  myprog.do  file you saved in the last lab.  We will now add some 
statements after  tabulate schooling  and before  log close . 

2. Labor-market experience is not available in the CPS-ASEC.  Let’s estimate it the way that many 
researchers do, as age minus years of schooling minus 6.  Write a  generate  command to 
compute the new variable  exper . 

3. Write another  generate  command to compute  expersq , the square of  exper . 

4. The hourly wage is not available in the ASEC.  Let’s estimate it as wage income divided by weeks 
worked and by hours per week, that is,  incwage/uhrsworkly/wkswork1.  Stata’s natural log 
function is either  log( )  or  ln( ) .  Write a  generate  command to compute  lwage , the 
natural log of the estimated wage. 

5. We need to exclude some of the observations with missing or irrelevant data.  There are many ways 
to do this.  I like to generate a special zero-one variable, which I call  ok2use,  to flag useable 
observations as follows: 

generate  ok2use =  educ>1 & age>15 & wkswork1>0  /// 
  & uhrsworkly<99 & incwage<9999998 

 
6. Before running the regression, add these commands to check the data: 

summarize schooling exper lwage  if ok2use 
histogram lwage  if ok2use 
 

7. Finally, add the regression command for the Mincer equation: 
regress lwage schooling exper expersq if ok2use, vce(robust) 
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Choose Tools>Execute (do) or click on the corresponding button to run your  do-file.  (Note that if 
you get an error message (in red) you will have to fix your program in the Do-File Editor and type 
“log close” in the Command window before running it again.) 

8. Do your results make sense?  Comment on the sign and value of each estimated coefficient 
schooling __________________________________________________________________ 
exper __________________________________________________________ 
expersq ________________________________________________________ 

 
9. If everything looks good, erase the stars in front of the commands log using... and log close   

and run the do-file one more time to create a log file of your output.  Save your do-file, giving it the 
same name as log file name above (it will be assigned a different extension).  Upload your log-file to 
Blackboard. 

10. When exiting Stata, do NOT save your data.  Otherwise, you will get errors the next time you run 
your do-file. 

 

[end of lab] 

Section B:  Stata Lab Instructions Page B-19

ECON 190 - Seminar: Inequality © 2023  William M. Boal



ECON 190 – Seminar:  Inequality  
Drake University, Spring 2023  
William M. Boal  

 Stata commands:   regress 
Topics:  requirements for an instrument  

(see Angrist & Pischke, 2015, p.106)  
 

Instrumental Variables Lab 
Part 1 of 2:  Finding an instrument 

Many people have hypothesized that estimates of the return to schooling, from ordinary least squares 
(OLS) applied to an equation like 

lwage  =  β1  +  β2 schooling  +  controls, 

suffer from “ability bias,” a type of selection bias or omitted-variable bias.  The most able people get 
more schooling, they hypothesize, so the OLS estimate of schooling coefficient confounds both the true 
return to more schooling and the return to greater (but unobserved) ability.  The implication of this 
hypothesis is that OLS estimates of the return to schooling, which typically range from 7% to 12%, are 
biased up. 

One way to tackle ability bias is to use the method of instrumental variables (IV).  In this lab, we 
replicate IV estimates originally made by labor economist (and Nobel Prize winner) David Card. 

1. From Blackboard, download and save the raw data file  card.raw  and the Stata do-file  
ivexample.do . 

2. From Stata, open the do-file, which already contains an  infile  command to read the raw data.  
Evidently, the data file contains lots of variables, most of which we will ignore.  For this exercise, the 
outcome is a variable called  lwage  and the treatment is called  educ.  What do these variables 
measure?  [Hint:  check the  label  statements in the do-file.] 
lwage = ____________________________________________________________________ 
educ = _____________________________________________________________________ 

3. The do-file already contains a  regress  command to estimate the relationship between  lwage  
and  educ  using ordinary least squares (OLS), with some control variables.  In words, what do these 
variables control for? 
____________________________________________________________________________ 
____________________________________________________________________________ 
____________________________________________________________________________ 

4. Run the do-file.  What is the OLS estimated rate of return to schooling?  _________________ 
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5. Card’s idea was to use the variable  nearc4  as an instrument.  What does  nearc4  measure? 
nearc4 = ___________________________________________________________________ 
Why did Card measure  nearc4  in 1966 but measure  wage  and  lwage  in 1976? 
____________________________________________________________________________ 
____________________________________________________________________________ 

6. Do you think  nearc4  meets the three requirements of an instrument for  educ ? 
(i) Relevance:  Does  nearc4  likely have a causal effect on educ?  Explain. ______________ 
____________________________________________________________________________ 
____________________________________________________________________________ 
____________________________________________________________________________ 
(ii) Independence:  Is  nearc4  likely uncorrelated with unobserved ability?  Explain. ______ 
____________________________________________________________________________ 
____________________________________________________________________________ 
____________________________________________________________________________ 
(iii) Exclusion:  Could  nearc4  realistically affect lwage through any channel except  educ?  
Explain.  _____________________________________________________________________ 
____________________________________________________________________________ 
____________________________________________________________________________ 
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 Stata commands:  regress, ivregress 

 

Instrumental Variables Lab 
Part 2 of 2:  Estimation 

We will now estimate the equation of interest, 

lwage  =  β1  +  β2 schooling  +  controls , 

using the method of two-stage least squares with  nearc4  as an instrument. 

1. Write out the reduced-form equation for lwage. 
 
lwage = _____________________________________________________________________ 

2. Insert a Stata command to estimate the reduced form equation using regress (be sure to include 
the option for robust standard errors) and rerun the do-file.  What is the estimated coefficient of 
nearc4?  ______________________  What is its standard error? ______________________ 
Angrist and Pischke (2015, p. 146) advise that “if you can’t see it in the reduced form, it ain’t there.”  
Is something there?  ___________________________________________________________ 
____________________________________________________________________________ 

3. We will now estimate the return to schooling using the method of two-stage least squares (2SLS), a 
variant of instrumental variables.  Write out the first-stage equation. 
 
educ = ______________________________________________________________________ 
Write out the second-stage equation. 
 
lwage = _____________________________________________________________________ 

4. Insert a Stata command to estimate both stages at once using ivregress.  The syntax is as 
follows: 

ivregress 2sls lwage control variables (educ = nearc4), 
first vce(robust) 

Remember to use /// if you must continue on the next line.  Rerun the do-file. 

5. The first stage equation can be used to check the first requirement of an instrument, often called 
“relevance.”  In this case, we want to check whether  nearc4  really has a causal effect on educ.  A 
popular rule of thumb is that the overall F-statistic should be at least 10.  What is the value of the F-
statistic for the first stage?  F = ____________________ 
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7. The second stage estimates the parameter of interest—in this case, the return to schooling.  
According to the second-stage results, what is the estimated rate of return to schooling?  
__________________________  What is its standard error? __________________________  

8. Compare the 2SLS estimate of the return to schooling with the OLS estimate from part 1.  Which is 
larger? _____________________________________________________________________ 

9.  Comment on the hypothesis of ability bias.  Does it appear that our OLS estimate was biased up, as 
predicted by this hypothesis?  Explain.  ____________________________________________ 
____________________________________________________________________________ 
____________________________________________________________________________ 
____________________________________________________________________________ 
____________________________________________________________________________ 
____________________________________________________________________________ 
____________________________________________________________________________ 

7. Remove the comment stars (*) from the  log using  and  log close  statements.  Rerun your 
do-file to create a log file of results.  Then save your do-file.  Upload your log-file to Blackboard. 

 

[end of lab] 
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 Stata commands:   summarize, twoway 

 

Regression Discontinuity Lab 
Part 1 of 3:  Look at the data 

If treatment changes abruptly according to some rule, we have a regression discontinuity design (RDD) 
which offers the possibility of causal inference.  In this lab, we reproduce the results for a sharp RDD 
model described in Angrist and Pischke (2015, chapter 4, section 4.1).  The data are taken from an article 
by Carpenter and Dobkin (2009) studying the effects of the minimum legal drinking age (MLDA) on death 
rates in the U.S.  In this lab, we will reproduce some of the results of that study as summarized by 
Angrist and Pischke (table 4.1, figure 4.2, and figure 4.4). 

1. From Blackboard, download and save the data file  AEJfigs.dta  and the Stata do-file  
rddexample.do . 

2. Using Stata, open the do-file, which already contains a  use  command to read the data and several 
other commands.  Run the do-file and look at the output from the  summarize  command.  
Evidently, the data set includes many causes of death, any one of which could be an interesting 
outcome variable to study.  In this lab, we will estimate the effect of the legal drinking age on the 
outcome variable  all , the death rate from all causes.  What is its mean value?  
___________________ deaths per 100,000. 

3. The variable  agecell  shows the age at which each death rate is calculated.  
What is the oldest age in the data set?  __________ years and __________ months. 
What is the youngest age in the data set?  __________ years and __________ months. 
What is the average age in the data set?  __________ years and __________ months. 
How many months are evidently included in the data set?  __________ months. 

4. The  twoway  command generates a  scatter  plot of all deaths against age (the variable 
agecell).  Do you see any relationship between age and death rates? 
____________________________________________________________________________ 
____________________________________________________________________________ 
____________________________________________________________________________ 
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 Stata commands:  regress, predict, 
twoway, graph export 

 

Regression Discontinuity Lab 
Part 2 of 3:  “Simple” RDD estimation 

We will now edit the  do-file to estimate a “simple” model of the death rate, using a linear parametric 
specification.  Then we will replicate figure 4.2 (page 150) in Angrist and Pischke (2015).  The equation to 
estimate is 

outcome =  β1  +  β2 treatment variable  +  β3 running variable  +  error term .1 

1. What should be our running variable for this RDD?  _____________________________________ 
The coefficient estimates are easier to interpret if the running variable is centered to equal zero at 
the point of treatment—that is, age 21.  Open the  do-file.  After the  twoway  command, but 
before the second  clear  command, insert this Stata command: 
 
generate  age = agecell – 21 

2. In this data set, the treatment variable does not yet exist.  To create it, insert the following Stata 
command: 
 
generate  over21 = (agecell >= 21) 

 
Note that the expression in parentheses is a logical expression.2  If the expression is true, then  
over21  equals one.  If false, then  over21  equals zero.  Thus  over21  is a zero-one dummy 
variable representing treatment. 

3. Now insert a Stata command to regress  all  on  the treatment variable and the running variable.  
Run the  do-file.  What is your estimated effect of the MLDA?  _____________ deaths per 100,000.  
Does your estimate match the one reported in Angrist and Pischke (2015) in table 4.1 on page 160, 
top of column (1)?  _______________ 

4. Let’s create a scatter plot with both the original data and the fitted value from the regression.  First, 
immediately after your regression command insert a command to save the fitted values of the 
regression: 
 
predict allfitsimple 

 
1 This is similar to equation (4.2) in Angrist and Pischke (2015, p. 152). 
2 The parentheses are not necessary.  They are used here simply to make the Stata code easier to read. 
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5. Then insert a command to create a graph similar to figure 4.2 in the Angrist and Pischke book: 
 
twoway (scatter all agecell) /// 
  (line allfitsimple agecell if age<0) /// 
  (line allfitsimple agecell if age>=0) 
 

The  twoway  command can overlay many plots, each enclosed in parentheses.  Here, we overlay a 
scatter plot of the raw data for all ages, a line plot of the predicted values before age 21 years, and a 
line plot after age 21 years.  Run the  do-file.  Does your graph resemble figure 4.2 (page 150) in 
Angrist and Pischke (2015)? 

6. Your graph should resemble figure 4.2 in substance but not in formatting.  Fortunately, Stata has a 
huge range of graphing options to adjust the formatting of graphs.  Remember that options to Stata 
commands follow a comma.  Edit your  twoway  command to add formatting options as follows.3 
 
twoway (scatter all agecell) /// 
  (line allfitsimple agecell if age<0) /// 
  (line allfitsimple agecell if age>=0), /// 
  legend(off) ytitle("Deaths per 100,000") ylabel(80(5)115) /// 
  title("Figure 4.2" /// 
  "A sharp RD estimate of MLDA mortality effects") 
 

Then run the  do-file again.  Does the formatting match figure 4.2 now?  Can you figure out what all 
these options do? 

7. Add one more command to save your graph.  Stata can save graphs in a variety of file formats.4  
Let’s use JPEG format, indicated automatically by the  .jpg  file extension.  Add the following 
command: 
 
graph export fig42.jpg, replace 

 
Then run the do-file again. 

  

 
3 Add your own formatting options!  Choose Help > Stata command ... and type “twoway options” to see 
formatting possibilities. 
4 Choose Help > Stata command ... and type “graph export” to see possible file formats. 
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 Stata commands:  regress, predict, 
twoway, graph export 

 

Regression Discontinuity Lab 
Part 3 of 3:  “Fancy” RDD estimation 

In Section 2 of this lab, we estimated a “simple” RDD model using a simple linear control for age.  Now 
we estimate a “fancy” RDD model that allows the control to be quadratic and to differ before and after 
treatment.  Then we will replicate figure 4.4 (page 158) in Angrist and Pischke (2015). 

1. Open the  do-file.  After the  graph export  command, but before the second  clear  
command, create the square of  age: 
 
generate  age2 = age^2 

2. Next, create interactions between the  over21  dummy variable and the age variables.  When 
these interactions are included in the regression, the coefficients of age and age-squared are 
allowed to differ before and after the treatment. 
 
generate over_age = over21*age 
generate over_age2 = over21*age2 

3. Then regress the death rate from all causes on the treatment variable, age and age-squared, and the 
interactions: 
 
regress all over21 age age2 over_age over_age2 
 

Run the  do-file.  What is your estimated effect of the MLDA?  _____________ deaths per 100,000.  
Does your estimate match the one reported in Angrist and Pischke (2015) in table 4.1 on page 160, 
top of column (2)?  _______________ 

4. Immediately after your regression command insert a command to save the fitted values of the 
regression: 
 
predict allfitfancy 

5. Then insert a command to create a second graph similar to figure 4.4 in the Angrist and Pischke 
book.  This graph needs to overlay a scatter plot of the raw data for all ages, line plots of fitted 
values of the “simple” model estimated in the last section of this lab, and line plots of fitted values 
of the “fancy” model just estimated, for a total of 5 plots.  
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twoway (scatter all agecell) /// 
  (line allfitsimple allfitfancy agecell if age<0) /// 
  (line allfitsimple allfitfancy agecell if age>=0) 
 

Run the  do-file.  Does your graph resemble figure 4.4 (page 158) in Angrist and Pischke (2015)? 

6. Your graph should resemble figure 4.4 in substance but not in formatting.  Edit your  twoway  
command to add formatting options as follows.  
 
twoway (scatter all agecell) /// 
  (line allfitsimple allfitfancy agecell if age<0, lpattern(dash)) /// 
  (line allfitsimple allfitfancy agecell if age>=0, lpattern(dash)), /// 
  legend(off) ytitle("Deaths per 100,000") ylabel(80(5)115) /// 
  title("Figure 4.4" "Quadratic control in an RD design") 
 

Then run the  do-file again.  Does the formatting match figure 4.4 now?  Can you figure out what all 
these options do? 

6. Add one more command to save your second graph in JPEG format: 
 
graph export fig44.jpg, replace 

 
7. Remove the comment stars (*) from the  log using  and  log close  statements.  Rerun your 

do-file to create a log file of results.  Then save your do-file.  Upload your log-file to Blackboard. 

 

[end of lab] 
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 Topics:  Downloading NLS data 

 

National Longitudinal Surveys Lab  
Part 1 of 4:  Extract data using NLS “Investigator” 

The National Longitudinal Surveys are a collection of survey studies sponsored by the U.S. Bureau of 
Labor Statistics.  Each survey follows a group of people roughly the same age, called a “cohort,” over 
time.  The survey data are housed at the Center for Human Resources Research at Ohio State University.  
Anyone can access the data for free through a website called the “NLS Investigator,” though you must 
register.  For this lab we will use the NLSY79, which follows a cohort of about 12,000 people born 
between 1957 and 1964 and first interviewed in 1979.  Although you can download an entire survey, the 
data set is enormous so this is inadvisable.  It is easier to download only the variables, individuals, and 
years that you need. 

1. Go to www.nlsinfo.org/investigator .  Click “Register” in the top right corner of the screen and 
complete the information.  Remember your password.  You will be sent an email to confirm your 
registration.  Follow the instructions. 

2. Log in using your new username and password.  You will be asked to select the study you want to 
work with.  For this lab, choose the NLSY79 (National Longitudinal Survey of Youth 1979). 
 
To access data from the NLS Investigator, you must check (or “tag”) the variables you need, thereby 
creating a “tagset” or list of wanted variables (similar to a “cart” at IPUMS).  Like other data 
websites, the NLS Investigator automatically “tags” certain standard variables. 
 
The unit of observation in NLS data is the individual person.  Data for different years on the same 
individual are stored as different variables in the same observation—so-called “wide” format.  As 
you might expect, this arrangement yields an enormous number of variables for each individual.  To 
get the years you want, you must search through many similar variables for different years.  For this 
exercise, we will search the NLSY79 for variables for the years 1985 through 1993. 
 
Let’s find some data to estimate the effect of education, experience, and union membership on pay.  
The NLSY79 has remarkably detailed data regarding work experience.  Information about all jobs 
held during the previous year is recorded.  For this exercise, we will use data only on “Job #1,” which 
is the current or most recent job.  Note that in variable titles, the letter “R” stands for “Respondent,” 
the individual person. 

3. Choose the tab “Variable Search.”  The second set of tabs shows several tools for finding variables in 
the NLS—we will start with the “Browse Index” tool. 
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o Let’s find education level.  In the “Index of Selected Variables,” choose  Education, Training 
& Achievement Scores>Education>Summary measures>All schools>By year>Highest grade 
completed.  Check the variable R1890901 “Highest grade completed as of May 1 Survey year 
(revised)” in 1985.  (We will assume for this lab that “highest grade completed” does not 
change over time—a longer research project should verify this.) 

o Notice, by the way, that when you hover your mouse over a variable name, a handy box 
appears with information from the codebook, including a tabulation of values. 

o Let’s find hourly wage.  In the “Index of Selected Variables,” choose  Employment>Summary 
measures>By job>Hourly wages.  Then click the header “VARIABLE TITLE” to sort the results.  
Check all nine variables with title “Hourly rate of pay job #01” for the years 1985 through 
1993. 

4. Let’s also get the age of the respondent, this time using the “Browse Index with Search” tool. 
o Under “Create search criteria below,” remove the gray line boxes referring to “Hourly 

wages.” 
o In the remaining white line of boxes, choose “Word in Title (enter search term),” “contains,” 

and in the empty box type at right, type “age of R at interview date”.  Click “Display 
Variables.”  Then click the header “VARIABLE TITLE” to sort the results. 

o Check all nine variables with title “Age of R at interview date” for the years 1985 through 
1993. 

5. Finally, let’s also get union status, this time using the third tool, “Search.” 
o Pick “Word in Title (pick from list),” “is,” “COLLECTIVE.”  Click “Display Variables.”  Then click 

the header “VARIABLE TITLE” to sort the results. 
o Check all nine variables with the title “Wages set by collective bargaining? Job #01” for the 

years 1985 through 1993. 

6. Let’s see what variables are now in our “tagset” (cart).  Choose “Review Selected Variables” in the 
top row of tabs.  You should see four default variables (“Identification code” through “Sex of R”) and 
the 28 variables we have tagged (checked).  If anything is missing, redo the previous steps. 

7. Now choose the tab “Save/Download” in the top row of tabs. 
o Choose “Save Tagset” in the second row of tabs to store your list of desired variables 

(similar to a “cart” at IPUMS).  Click the radio button for “Save on our server” and the radio 
button for “By Rnum”.  Then give it a sensible “Filename” and click “Save.” 

o Now choose “Basic Download” in the second row of tabs and click “Download.”  The NLS 
Investigator will create a compressed zip folder of your data and related files.  It might take 
a few seconds. 

o Choose “Manage Downloads” in the second row of tabs and click “Download” to download 
and save the zipped folder.  (If you forgot to give it a name, it will be called “default.zip.”)  
Move the zipped folder to a convenient folder on your computer. 

o Click “Logout” in the upper-right corner of the NLS Investigator web page. 
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 Stata commands:  log, infile, 
describe, rename, 

 

National Longitudinal Surveys Lab  
Part 2 of 4:  Open NLS data in Stata  

The folder you downloaded from NLS Investigator is in a standard compression format, so you will not 
need any special software to unzip it.  If you click on the downloaded zip folder, you will see that it 
contains many files.  Which ones do you need?  Many of the files have the same file name but different 
file extensions ( .something).  Set your computer so that you can see file extensions. 

 Mac users:  In the Finder>Preferences menu, select the Advanced tab and check the box “Show 
all filename extensions.” 

 Windows users:  In the File Manager window, select the View tab and check the box “File name 
extensions.” 

The data are in three files which contain the same information in different formats as indicated by their 
extensions:  free-form (.dat) or spreadsheet (.csv) or “Stata dictionary” (.dct).  You could read the data 
into Stata from any one of these files, but the “Stata dictionary” is probably the easiest. 

1. Create a folder on your computer for this lab.  Copy the .dct file to that folder. 

2. Open Stata.  Choose File>Change working directory... and make sure Stata is pointing to the folder 
with the  .dct file. 

3. Choose Window>Do-file editor>New do-file editor.  Write the following simple program to check 
your download: 
 
* Program to analyze NLSY79 

* log using  your program file name , text replace 
infile using  your data file name.dct, clear 
describe 
clear 
* log close 
 

To minimize confusion, the log file should be given the same name that you plan to give this do-file.  
Run the do-file.  The command  describe  should report in the results window that you have 32 
variables and over 12,000 observations.  Recall that each observation is an individual person—that 
is, the data are in “wide” format. 
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5. The output from  describe  also shows the names of the variables, which all consist of R followed 
by 7 digits, and the variable labels (which are more informative).  Let’s give better names to the 
variables we will use.  Be sure to include the year at the end of the new name of any variable 
observed in multiple years—Stata will use this information later.  So insert the following statements 
after  describe  and before  clear : 
 
rename R0000100 personid 
rename R0214800 sex 
rename R1810710 wage85 
rename R1811000 union85 
rename R1890901 schooling 
rename R1891010 age85 

(etc.) 
rename R4418700 age93 
rename R4200000 union93 
rename R4416900 wage93 

 
To speed this tedious coding task and reduce errors, I recommend you copy the output from 
“describe” directly into your do-file, and then edit it. 

6. Add a “summarize” command after the last “rename,” and rerun the do-file. 

7. Do the descriptive statistics make sense?  Consult the codebook ( .cdb) that was included in the zip 
file.  Why are there so many negative values, as revealed by the “Min” column? 
 
________________________________________________________________________________ 
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 Stata commands:  foreach, sort, 
generate, regress 

 

National Longitudinal Surveys Lab  
Part 3 of 4:  Estimate the effect of unionism on wages 

using cross-section data 

Let’s clean up the data a bit and estimate a Mincer wage equation with unionism. 

1. Last time, we discovered that many of our variables have negative values.  According to the 
codebook, these indicate data that are missing for some reason.  To prevent Stata from using these 
negative values, we need to change them to Stata’s own code for missing values, a decimal point.  
This could be done with a long series of “replace” commands, one for each variable, but there is an 
easier way using a  foreach  loop. 
 
foreach x of varlist sex schooling wage* union* age*{ 
  replace `x’ = .  if `x’<0 
  } 

 
In a Stata  foreach  loop, any statements between the curly braces (here there is only one) are 
executed for each of the variables following  varlist .  The expression  wage*  stands for all 
variables beginning with  wage , and similarly for  union*  and  age* .  Note that in the second 
line,  x  is bounded on the right by a single quote and on the left by a left single quote, which is 
usually found in the upper-left corner of a computer keyboard.  
 
After the  foreach  loop, insert a  summarize  command to check the results.  Are the negative 
values gone from the “Min” column?  ________________________________________________ 

2. Suppose we are interested in the effect of unions on wages.  Let’s compare the average wages of 
union and nonunion workers in, say, the year 1985.  At the same time, let’s check for balance 
between the two groups of workers.  Add the following commands and rerun your do-file. 
 
sort union85 
by union85: summarize wage85 sex schooling age85 

 
Are the average wages similar?  ____________________________________________________ 
But are union and nonunion workers similar in other respects? ___________________________ 

3. Multivariate regression provides one way of controlling for differences between groups.  Recall that 
a Mincer wage equation relates a person’s log wage to schooling and labor-market experience.  Let’s 
estimate a variation on a Mincer equation that includes the effect of union coverage, a zero-one 
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variable: 
 

ln(wage)  =  β1  +  β1 schooling  +  β3 experience  +  β4 experience2  +  β5 union  . 
 
Estimate this equation with Stata’s  regress  command using data for 1985 only, a cross-section 
regression.  (You will first need to  generate  the variables  lwage85 ,  exper85 ,  and  
expersq85 .)  Do the estimated values of the coefficients make sense?  __________________ 
Which ones are statistically significant? _____________________________________________ 

4. Stata’s default standard errors are not robust to heteroskedasticity.  For robust standard errors, add 
a comma and the option  vce(robust)  to the  regress  command.  Do the standard errors 
change? ________________________________________________________________________ 

5. Rerun your do-file.  Examine the regression results and think about whether the estimated 
coefficient of  union  has a causal interpretation. 
What is the treatment group?  ______________________________________________________ 
What is the control group?  _________________________________________________________ 
Do you believe the groups are alike, on average (aside from differences in education and experience, 
which we controlled for)?  Or do you suspect people who join unions might command higher wages 
even if they were not union members?  If the latter, we face a problem of selection bias in 
estimating the effects of unionism on wages. 
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 Stata commands:  drop, reshape, 
list, summarize, generate, 

xtset, xttab, xtreg 

 

National Longitudinal Surveys Lab  
Part 4 of 4:  Estimate the effect of unionism on wages 

using longitudinal data 

One possible way to eliminate selection bias is to track the same individuals over time, before and after 
treatment.  National Longitudinal Survey data are well-suited for this approach because the same 
individual is tracked for many years, as indicated by the adjective “longitudinal.”  To measure the effect 
of unionism on wages, we can compare the wages of the same worker before and after a change of 
union status.  This is easiest in Stata if we first rearrange the data set from wide format to so-called long 
format where each observation is a person-year rather than simply a person. 

1. First, drop the variables created earlier for cross-section regression: 
 
drop lwage85 exper85 expersq85 

 
Use the following powerful Stata command to simultaneously rearrange the data into long format, 
strip the years from the variable names  union,  age,  and  wage, and create a new time variable 
to be called  year : 
 
reshape long union age wage, i(personid) j(year) 

 
Let’s check whether the  reshape  command actually worked as intended.  Insert a command to 
list the first 30 or so lines of data and another command to compute summary statistics: 
 
list in 1/30 
summarize 

 
Rerun your do-file.  The  list  command should display all the observations for person #1, followed 
by the observations for person #2, etc.  The  summarize  command should show that you have 
nearly nine times as many observations as before, because there are potentially nine years of data 
(1985-1993) for each person. 

2. Add more commands to generate the new variables we need for panel regression: 
 
generate lwage = ln(wage) 
generate exper = age – schooling – 6 
generate expersq = exper * exper 
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3. Now our longitudinal approach will only work if some individuals in our data actually did switch from 
union jobs to nonunion jobs or vice versa.  We can check this with the following commands. 
 
xtset personid year 
xttab union 

 
In Stata,  xt  at the beginning of a command stands for “cross-section time-series”—that is, 
longitudinal or panel data.  The  xtset  command tells Stata which variable denotes the individual 
and which variable denotes the time period.  It must precede all other Stata  xt  commands.   
 
The  xttab  command asks for a tabulation of the variable  union  showing its variation both 
between individuals and within individuals (over time).  Rerun your do-file.  Examine the output 
from the  xttab  command, focusing on the column headed “Between/Freq.”  It should show that 
roughly 10,000 individuals had a least one year with a nonunion job (union=0), and roughly 4000 
individuals had at least one year with a union job (union=1).  But since  n  equals only about 11,000 
individuals, as shown at the bottom of the table, there must have been several thousand individuals 
in both categories—that is, individuals who actually switched union status.  Using a calculator, 
compute the exact number of such individuals: ___________. 

4. If we have multiple observations on each person, we can control for all differences across people 
(that do not change over time) by introducing dummy variables for each person.  However, it would 
be impractical to write a  regress  command with 10,000 or so dummy variables (and the 
computer memory requirement would be prohibitive).  Fortunately, there is a practical alternative.  
Panel regression with so-called “fixed effects” is equivalent to including dummy variables for each 
individual person.  Insert the Stata command for panel regression with fixed effects: 
 
xtreg lwage  exper expersq union, fe vce(robust) 

 
The option  fe  specifies fixed effects.  The option  vce(robust)  requests that standard errors 
be computed using a formula robust to serial correlation of errors (within each individual), and to 
heteroskedasticity (of any kind).  These are sometimes called “cluster standard errors” or more 
precisely “standard errors clustered on individuals.” 
 
Note that the variable  schooling  is omitted from this regression equation—coefficients of 
variables that vary across individuals but not over time cannot be estimated because those variables 
are perfectly collinear with individual dummies (implicit in fixed effects).  If you insist on including  
schooling  as a regressor, Stata will refuse to compute its coefficient. 

5. Rerun your do-file.  Compare the estimated coefficient of  union  with the coefficient of  union85  
in the cross-section regression for 1985 as estimated in part 3 of this lab.   
 
Which is larger?  __________________________________________________________________ 
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Do the results suggest positive or negative selection bias in the cross-section regression?  Put 
differently, would people working at union jobs command higher or lower wages than average, even 
if they were not working at union jobs? ________________________________________________ 
_________________________________________________________________________________ 

6. Remove the comment stars (*) from the  log using  and  log close  statements.  Rerun your 
do-file to create a log file of results.  Then save your do-file.  Upload your log-file to Blackboard. 

 

[end of lab] 
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 Stata commands:  summarize, tab1, 
describe 

 

Consumer Expenditure Surveys Lab  
Part 1 of 4:  Download data from BLS-CE 

The Consumer Expenditure Surveys (CE), conducted by the U.S. Bureau of Labor Statistics, survey 
American “consumer units” (CUs, or households) on their spending.  The CE actually consists of two 
quarterly surveys—an Interview Survey, in which respondents are interviewed about spending on major 
items over the last quarter, and a Diary Survey, in which respondents are asked to record all spending 
over a week for two weeks in succession.  Both surveys also collect a large amount of data on household 
characteristics, including various forms of income, family size and configuration, and education. 

The data collected by the CE have a variety of uses.  In particular, they are used to weight the prices in 
the monthly Consumer Price Index.  They are also published, cross-tabulated by household 
characteristics like age, income, education, and family size, in detailed tables available at 
https://www.bls.gov/cex/tables.htm .   

Finally, the underlying data are used to create “Public Use Micro Data” (PUMD) files, available for free 
download.  The PUMD files are slightly redacted through top-coding and similar edits so that individual 
respondents cannot be identified, but they are still useful for economists.  Let’s download a recent year 
of PUMD files from the Diary Survey. 

1. Go to https://www.bls.gov/cex/pumd_data.htm .  (Note the underscore between “pumd” and 
“data”.)  Choose the “STATA” tab.  In the row for “2021,” click on “Diary (zip)” and download the 
zipped (compressed) folder to your computer. 

2. Just above, download “Dictionary for Interview and Diary Surveys (XLSX)”.  This file lists the variables 
available in the CE Survey (though not every variable is available in every year).   Save it for future 
reference.  Then close your browser. 

3. Unzip the Diary data folder.  In Windows, right-click on it and choose “Extract all”.  On a Mac, double 
click on it.  You should see 20 files ending with the extension “ .dta” which indicates a Stata data file 
(set your computer so that you can see file extensions).  The first three letters of each file name 
indicate its contents (see the Dictionary XLSX file for more information).  The fourth letter is “D” for 
diary.  The last three numbers of each file name indicate the year and quarter. 

4. Let’s inspect the FMLD file for the first quarter of 2020:  fmld211.dta .  Double-click on the unzipped 
version of fmld211.dta .  Stata should start and open the file.  Stata’s “Properties” window should 
show that there are over 300 variables and nearly 3000 observations.  A list of variable names 
should appear in Stata’s “Variables” window, but unfortunately there are no labels describing the 
variables.  In Stata’s “Command” window, type 
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summarize  FINCBEFX FOODHOME ALCBEV FRSHVEG 

Note that CE variables are all caps in the  .dta  file we downloaded.  Since Stata is case-sensitive, the 
CE variables must be written all caps in Stata commands.  Check the Dictionary XLSX file, “Variables” 
tab, to find out what these CE variables stand for.  Note that income data in the CE are annual but 
spending data are weekly (all in dollars).  Do the mean values look reasonable?  
_______________________________________________________________________ 
 

5. For continuous variables such as those above, summary statistics are helpful, but for discrete 
variables, a tabulation can be more informative.  In Stata’s “Command” window type 

tab1  FAM_SIZE VEHQ CUTENURE HIGH_EDU 

Check the Dictionary XLSX file, “variables” tab, to find out what these variables stand for.  Do the 
tabulated values look reasonable?  
__________________________________________________________________ 
 

6. Some discrete variables in the CE are stored as numbers (“double” or “float”), while others are 
stored as text (“str” or string) even if they appear to be numbers.  Find out which are which by 
typing the following in Stata’s “Command” window: 

describe  FAM_SIZE VEHQ CUTENURE HIGH_EDU 

Stata can tabulate any variable, but it can only do calculations (like  summarize) with numbers.  To 
see this, type the following in Stata’s “Command” window: 

summarize  FAM_SIZE VEHQ CUTENURE HIGH_EDU 

The output should report zero observations for the two string variables.  But the data are obviously 
not missing—they are just in string format so  summarize  cannot process them. 
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 Stata commands:  log, clear, 
append, summarize, log, exit, 

generate, sort, egen 

 

Consumer Expenditure Surveys Lab  
Part 2 of 4:  Estimate income elasticities 

We will now write a Stata do-file to compute the average income elasticity of demand for food, using 
the FMLD files.  

1. To get a bigger sample, we will combine four quarters of data into a single file using Stata’s  
append  command, which is used to tack on more observations (not more variables).  In Stata, 
choose Window>Do-file Editor>New Do-file Editor .  When the new window opens, type the 
following lines into the blank window: 

* Analyze Consumer Expenditure Diary Survey PUMD 

* log using log file name, text replace 
clear 
append using fmld211.dta fmld212.dta fmld213.dta fmld214.dta 
summarize FINCBEFX FOODHOME ALCBEV FRSHVEG 
clear 
* log close 
 
As usual, “log file name” can be any name you want, but to minimize confusion, use the same name 
that you plan to give this do-file when you save it. 

2. Point Stata at the folder with the unzipped data files (File>Change working directory…).  Then run 
the do-file.  summarize  should now report about four times as many observations as before, but 
the mean values of the variables should be roughly similar. 
 

3. An interesting feature of the Diary data files is that they contain two (weekly) observations for every 
consumer unit (CU).  Repeated observations on the same CU are surely serially correlated, so 
regression standard errors computed without taking this into account would be biased.  One 
solution to this problem is to combine serially-correlated observations by computing average weekly 
spending over the two weeks for each CU. 
 
As you know, Stata’s  generate  command can create new variables from old ones, but it operates 
only within observations.  To make calculations across multiple observations, we need Stata’s  egen  
(for “extension to generate”) command.  To compute average weekly food expenditures for each 
consumer unit, insert the following commands after  summarize  and before  clear: 
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sort CUID 
by CUID:  egen avgfoodhome = mean(FOODHOME) 
summarize FOODHOME avgfoodhome 

The  sort command is necessary because the  by  prefix requires that the data set be sorted first.  
Re-run the  do-file.  The mean of  avgfoodhome  should be identical to the mean of  foodhome,  
but with smaller standard deviation and smaller maximum. 
 

4. Now let’s regress spending on income and family size.  First let’s put all variables except education in 
logarithms, so that coefficients can be interpreted as elasticities.  This will create missing values for 
any observations with zero  or negative values, but hopefully there will be few of these.  Insert this 
command after  summarize  and before  clear: 

generate  lincome = ln(FINCBEFX) 
generate  lfamsize = ln(FAM_SIZE) 
generate  lfood = ln(avgfoodhome) 

Second, to avoid duplication, we will only use the first week (not both weeks) from each consumer 
unit.  The variable  WEEKI  takes the values 1 or 2 to indicate the week (according to the Dictionary 
XLSX file, “variables” tab).  Let’s create a flag variable based on  WEEKI  to ensure that we will only 
use week 1.  Now the Stata command  describe WEEKI  reveals that its type is actually “str2”, 
not numeric.  So we must use Stata’s  real  function, which converts string variables to numbers, 
as follows: 

generate ok2use =  real(WEEKI)==1 

Note that a double equal sign is used for testing equality, whereas a single equal sign assigns values 
to a variable in  generate  or  replace  statements.   
 
Third, insert the regression command after the  generate  commands and before  clear: 

regress lfood lincome lfamsize if ok2use, vce(robust) 

Re-run the do-file.  Now if all households face the same prices, then spending on food is 
proportional to the quantity they buy, and so the coefficient of log-income is the income elasticity of 
demand for food.  What is the estimated income elasticity?  _______________________________ 
What is the estimated elasticity of demand for food with respect to family size?  _______________ 
Do these values make sense?  ________________________________________________________ 
Are the estimates significantly different from zero?  ______________________________________ 

5. Suppose we suspect that education affects household preferences and therefore spending on food.  
We want to add one more regressor,  HIGH_EDU .  Although this variable appears to take 
numerical values, the Stata command  describe HIGH_EDU   reveals that its type is actually 
“str2”.  Stata can tabulate string variables, but it cannot use them in a regression.  So insert these 
commands after the first  regress  command and before  clear: 
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generate yearsedu = real(HIGH_EDU) 
regress lfood lincome lfamsize yearsedu if ok2use, vce(robust) 

Re-run the do-file.  Did the coefficient estimates change much?  _________________________  
Does education have a positive or negative effect on spending on food?  __________________ 
Is it statistically significant? _______________________________________________________ 

6. If you have time, use  generate  and  regress  estimate the income elasticity of demand for 
o alcoholic beverages (ALCBEV)   ______________________ 
o fresh vegetables (FRSHVEG)      ______________________ 
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 Stata commands:  describe, tab1, 
generate, summarize, regress 

 

Consumer Expenditure Surveys Lab  
Part 3 of 4:  Linear probability model 

Suppose we have a binary, yes-no dependent variable, such as whether the person is a homeowner.  
How can we estimate and interpret an econometric model explaining such a variable? 

1. The CE Diary Survey has a variable  CUTENURE  indicating homeownership.  In your Stata do-file, 
insert the following commands just before the last  clear: 

describe CUTENURE 
tab1 CUTENURE 

Then re-run your do-file.  You should see that  cutenure  is a string (“str2”) variable that takes six 
different code values, with 1, 2, and 4 being the most frequent.  Check the Dictionary XLSX file, 
“codes” tab,  to find out what these six values mean. 

cutenure = 1  means __________________________________________________ 

cutenure = 2  means __________________________________________________ 

cutenure = 3  means __________________________________________________ 

cutenure = 4  means __________________________________________________ 

cutenure = 5  means __________________________________________________ 

cutenure = 6  means __________________________________________________ 

2. Now let’s generate a new binary variable equal to 1 if the consumer unit (CU) owns their home, and 
equal to 0 if not.  Insert the following commands just before  clear: 

generate ownhome = real(CUTENURE)<4 
summarize ownhome 

Re-run the do-file.  Note that the mean of  ownhome  equals the fraction of CUs that own their 
homes.  What fraction of the CUs in our sample own their homes?  Is this value plausible? 

A zero-one random variable is called a Bernoulli random variable.  Let  Y  be a Bernoulli random 
variable that equals 1 with probability  p  and equals zero with probability  1-p.  Then using the 
definitions of mean and variance, we have 

E(Y) = p 1 + (1-p) 0 = p          Var(Y) = p (1-p)2 + (1-p) (0-p)2 = p (1-p) . 
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Now the  summarize  command reports both the sample mean and the standard deviation, which 

is  √𝑉𝑎𝑟.  Verify with a calculator that the standard deviation of  ownhome  is in fact equal to ,  

𝑚𝑒𝑎𝑛 (1 − 𝑚𝑒𝑎𝑛) . 

3. Let’s estimate a linear regression equation to explain  ownhome  .  Insert the following command 
just before  clear: 

regress ownhome lincome lfamsize if ok2use, vce(robust) 

Re-run the do-file. 

What does this linear regression model mean, given that  ownhome  is a zero-one variable?  The 
mean of the dependent variable is the fraction of CUs that own their own home, or alternatively, the 
probability that a particular CU owns their own home.  So a predicted value of the model is a 
predicted probability that a CU owns their own home, for any given values of  lincome and 
lfamsize .  Because the regression function is linear, this is called a linear probability model, and 
each coefficient gives the change in the probability of a CU owning their own home, for a one-unit 
change in the regressor. 

Now in our model, the regressors are in logarithms, and changes in logarithms are approximately 
equal to percent changes in the underlying variable.  So let’s reinterpret the coefficients in terms of 
percent changes in the underlying variables.  For example, suppose income increases by 10%.  Then  
lincome  (its logarithm) increases by 0.10.  So the probability of homeownership increases by 
0.10 times the coefficient of  lincome .  How much would that be, according to your estimates? 

Change in probability of homeownership for a 10% increase in income = _____________________. 
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ECON 190 – Seminar:  Inequality  
Drake University, Spring 2023  
William M. Boal  

 Stata commands:  logit, probit 

 

Consumer Expenditure Surveys Lab  
Part 4 of 4:  Logit and probit models 

When modeling a zero-one variable  yi , linear probability models like  

yi = β1 + β2 xi + εi 

are attractive because they are simple and easy to interpret.  However, they do have one awkward 
feature.  The fitted values are often greater than one or less than zero, values which are nonsensical for 
a probability.  Usually, interest lies in the coefficients, not the predicted values, but if sensible predicted 
values are important to our research project, then we need an alternative model where the fitted values 
are constrained to lie between zero and one.  The usual approach is to transform the right-hand side by 
finding an upward-sloping function  F(z)  that is bounded between zero and one, and estimating 

yi = F(z) + εi  ,    where  zi =  β1 + β2 xi 

The F(z) function should be some kind of S-curve that bends  z  so that  y  lies between zero and one. 

There are two popular choices for a F(z) function:  the logistic function  𝐹(𝑧) =
( )

( )
   and the 

standard normal cumulative distribution function  𝐹(𝑧) = Φ(𝑧) = ∫
√

𝑒𝑥𝑝  𝑑𝑤 .  When the 

logistic function is used for F(z), the model with the binary y-variable is called a logit model.  When the 
standard normal cumulative distribution function is used for F(z), the model is called a probit model. 

The advantage of logit and probit models is that the fitted values are always greater than zero and less 
than one, as probabilities should be, but there are some complications.  First, because logit and probit 
models are nonlinear, there are no simple formulas for the coefficient estimates.  Instead, estimation 
proceeds essentially by computerized trial-and-error.  If there are many  β  coefficients to estimate, it 
may take noticeably longer to compute the estimates than with a linear probability model. 

Second, the marginal effect of a one-unit change in  x  on  y  is more complicated than in the linear 

probability model, and it depends on  z.  Using the chain rule for differentiation,  = 𝐹′(𝑧) 𝛽  .  But all 

these complications are automated in Stata and other econometric software, so for the user it is usually 
just as easy to estimate logit or probit as it is to estimate a linear probability model. 

1. Let’s estimate a logit model for home ownership.  In your Stata do-file, insert these commands just 
before the last  clear: 

logit ownhome lincome lfamsize if ok2use 
margins, dydx(lincome lfamsize) atmeans 
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The first command estimates the logit model.  The second command computes  𝐹′(𝑧) 𝛽   for each 
regressor, using the value of  z  corresponding to the sample means of lfincaftx and 
lfam_size .  Run the do-file again. 

2. Let’s also estimate a probit model for home ownership.  In your Stata do-file, insert these 
commands just before the last  clear: 

probit ownhome lincome lfamsize if ok2use 
margins, dydx(lincome lfamsize) atmeans 

The first command estimates the probit model.  The second command computes  𝐹′(𝑧) 𝛽   for each 
regressor, using the value of  z  corresponding to the sample means of lfincaftx and 
lfam_size .  Run the do-file again. 

3. Now let’s compare the estimates for the linear probability model of the previous part of this lab with 
these new logit and probit estimates.  As you can see, all three sets of estimates are quite different 
from each other.  But this is no surprise—they are not comparable because of the F(z) functions.  
The linear probability model coefficient estimates are the estimated marginal effects of one-unit 
changes in the regressors, but the logit and probit coefficient estimates are not. 

For comparability, we should look at the estimated conditional marginal effects for the logit and 
probit models, as computed by the  margins  command.  These are usually much closer to each 
other and to the linear probability model.  Complete the following table to summarize your results.  
Put the standard errors of the marginal effects in parentheses. 

 Linear probability 
model 

Logit model Probit model 

 Estimated 
coefficients 

Estimated 
marginal effects 

Estimated 
marginal effects 

lincome   
(                              ) 

 
(                              ) 

 
(                              ) 

lfamsize 
 

 
(                              ) 

 
(                              ) 

 
(                              ) 

 

4. Remove the comment stars (*) from the  log using  and  log close  statements.  Rerun your 
do-file to create a log file of results.  Then save your do-file.  Upload your log-file to Blackboard. 

 

[end of lab] 
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SECTION C 
SLIDESHOW HANDOUTS 



SKILLED VERSUS 
UNSKILLED WAGES

• What determines the relative pay 
of skilled and unskilled workers?

Production with 1 input

• Production function:
q = q(x).

• x = input or factor of 
production.

• Marginal product of x:
MP = dq/dx .

• Example:
q(x) = 200 x1/2 .
MP = ____________.

Output = q

Input = x

Profit maximization with 1 input 
and all prices taken as given

• Let p = price of output, w = price of input.
• Profit = rev – cost  =  p q – w x  =  p q(x) – w x .
• To maximize profit, set derivative = 0:

p (dq/dx) – w = 0,  or  p MP = w.
• p MP called “value of marginal product,” VMP.
• So profit maximization implies ____________.
• (w/p) called “real wage,” so alternatively 

_____________________.

Production with 2 inputs

• Production function:  q = q(x1, x2 ).
• Can use this framework for many issues 

related to income inequality.  Examples:
• x1 = unskilled workers, x2 = skilled workers.
• x1 = labor, x2 = capital.

Graphing production with 2 inputs

• Graph with isoquants, 
connecting input 
combinations yielding 
same output.

• Isoquants usually 
slope down and are 
curved.

• Position depends on 
technology.

f(xU,xS) = 100 tons
f(xU,xS) =150 tons

xU

xS

f(xU,xS) = 50 tons

Marginal rate of substitution

• Marginal products:
MPU = ∂q/∂xU
MPS = ∂q/∂xS .

• MPS/MPU called 
“marginal rate of 
substitution” (MRS)
= |slope| of isoquant.

xU

xS
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Diminishing marginal rate of 
substitution

• MRS usually 
diminishes  xU
decreases and  xS
increases.

• Isoquants usually are 
curved.

xU

xS

Profit maximization with 
2 kinds of workers

• Let  wU , wS = wages of workers.
• Profit = rev – cost  =  p q(xU,xS) – wUxU – wSxS .
• To maximize profit, set derivatives = 0:

p (∂q/∂xU) – wU = 0  or   p MPU = wU
p (∂q/∂xS)  – wS = 0  or  p MPS = wS.

• So again profit maximization implies 
___________________________________.

Marginal rate of substitution equals 
ratio of input prices

• Divide second 
equation by first:

𝑝 𝑀𝑃

𝑝 𝑀𝑃
=

𝑤

𝑤

• Profit maximization 
implies MRS 
= |slope| of isoquant
= ratio of input prices.

xU

xS

Relative input prices negatively related 
to relative input quantities

• If isoquants are 
curved, MRS is 
negatively related to 
(xS/xU).

• So (wS/wU) negatively
related to (xS/xU), 
along an isoquant.

xU

xS

What if unskilled workers become 
relatively more expensive?

• Then |slope| of 
isoquants (wS/wU) 
decrease.

• Cost-minimizing firm 
chooses less  xU and 
more  xS.

• Firm substitutes away 
from unskilled 
workers.

xU

xS

What if skilled workers become 
relatively more expensive?

• Then |slope| of 
isoquants (wS/wU) 
increase.

• Cost-minimizing firm 
chooses less  xS and 
more  xU.

• Firm substitutes away 
from skilled workers.

xU

xS
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Elasticity of substitution (σ)

• Strength of firm’s response is called “elasticity 
of substitution”:

𝜎 = −
𝑑 ln 𝑥 𝑥⁄

𝑑 𝑙𝑛 𝑀𝑅𝑆
= −

𝑑 ln 𝑥 𝑥⁄

𝑑 𝑙𝑛 𝑤 𝑤⁄
> 0

• Effectively,  s (“sigma”) measures straightness 
of isoquants, or ease of substitution.

Strength of response to changes in (wS/wU) 
depends on straightness of isoquant

Weak response, _______ s. Strong response, ______ s.

xU

xS

xU

xS

Elasticity of substitution (σ) for 
various production functions

xS xS
xS

s = ______ s = ______ s = ______

Cobb-
Douglas

Fixed 
proportions

Linear

xU xU
xU

Same idea graphed as 
“relative demand curve”

• Wage ratio (wS/wU) 
must be negatively
related to relative 
demand for workers 
(xS/xU).

• In this diagram,  s  
measures flatness of 
relative demand 
curve.

wS/wU

xS/xU

Relative 
demand

Elasticity of substitution measures 
flatness of “relative demand curve”

Steep curve, __________ s. Flat curve, ___________ s.

wS/wU

xS/xU

Relative 
demand

wS/wU

xS/xU

Relative 
demand

Economy as a whole

• Individual firms take wages as given and 
choose their (xS/xU) to minimize cost of 
production.

• But for economy as a whole, total relative 
supply (xS/xU) is fixed in short run.

• So at least in short run, total (xS/xU) 
determines (wS/wU).
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Economy as a whole:  
relative demand and supply

• Relative supply is 
vertical, at least in 
short run.

• Relative wages 
(wS/wU) determined 
by intersection of 
relative demand curve 
with vertical relative 
supply curve (xS/xU).

wS/wU

xS/xU

Relative
supply

Relative 
demand

Change in relative supply 
in the long run

• In long run, if relative 
supply (xS/xU) 
increases, then 
relative price (wS/wU) 
decreases.

• Amount of decrease 
depends on flatness of 
relative demand, 
measured by elasticity 
of substitution (s).

wS/wU

xS/xU

Suppose elasticity of substitution (σ) 
is constant

• Recall definition:  𝜎 = −
⁄

 ⁄

• Taking reciprocals:  =
⁄

 ⁄

• If  σ is constant, then:  =
∆ ⁄

∆ ⁄

Using s to compute effect of relative 
supplies on relative wages 

Δ(xS/xU) Elasticity of 
substitution 

(s)

1

−𝜎

Δ(wS/wU)

+10% 0.8 %
+10% 1.0 %
+10% 1.5 %
+10% 2 %

Measuring elasticity of substitution (σ) 

• If  σ is constant, then:  =
∆ ⁄

∆ ⁄
 

• Suppose we have data on relative wages and 
relative supplies of skilled and unskilled 
workers over time.

• Could fit this equation to data by LS:

𝑙𝑛
𝑤

𝑤
= 𝑎 +

1

−𝜎
 ln

𝑥

𝑥

Conclusions

• The marginal product of workers equals the increase in 
output from one more worker.

• Competition implies that, for any skill level, workers’ 
wage equals the value of marginal product.

• The marginal rate of substitution is the |slope| of 
isosquants, and equals the ratio of marginal products.  

• The elasticity of substitution (σ) measures the 
straightness of isoquants, or the ease of substitution.

• Relative worker wages (wS/wU) are negatively related 
to relative supplies (xS/xU) of workers, ceteris paribus.  
This negative relationship is stronger if  σ is smaller.
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1/5/2023

1

OMITTED VARIABLE 
BIAS FORMULA

ECON 190

What happens if a variable is omitted 
from a regression equation?
Suppose wages depend on education and ability:

W  =  β1 +  β2 E  +  β3 A +  εW ,
where  β2 > 0  and  β3 > 0.  We want to measure the 
effect of  E,  the treatment variable, on  W.  But 
suppose we don’t have data on  A.  
Is there a problem if we just leave  A  out of the 
regression equation?

A little algebra

Again:
W  =  β1 +  β2 E  +  β3 A +  εW ,

Now suppose that education and ability are 
correlated.  We can express this correlation as 
another regression equation:

A  =  π1 +  π2 E  + εA .
Substitute:

W  =  β1 +  β2 E  +  β3 (π1 +  π2 E  + εA) +  εW

W  =

Formula for omitted variable bias

So instead of estimating :
W  =  β1 +  β2 E  +  β3 A +  εW ,

ordinary least squares will estimate:
W  =  (β1+β3π1)  +  (β2+β3π2) E  +  (εW+β3 εA).

Our estimate of the coefficient of  E  is biased due to 
an omitted variable (A).  Bias = _________.
In words, omitted variable bias equals 

{effect of omitted [A] in long equation} ×
{regression of omitted [A] on included [E]}.

Formula for omitted variable bias:  
numerical example
Example in Angrist and Pischke, pp. 69-72:

Y  =  β1 +  β2 P  +  β3 A +  εY ,
A  =  π1 +  π2 P  + εA .

Here, Y = earnings, P = attendance at private college, 
and A = ability (or “applicant group”).
If A is omitted in the top equation, formula for 
omitted variable bias = _________.
Suppose  π2 = (1/6)  and  β3 = 60,000.  
Then bias = __________.

Formula for omitted variable bias:  
qualitative example
Often we can only guess the sign (+/-) of omitted variable 
bias.

productivity  =  β1 +  β2 workday  +  β3 machines +  εY ,
machines  =  π1 +  π2 workday  + εA .

If machines are omitted from first equation, formula for 
omitted variable bias = _________.  
Suppose we guess  π2 < 0  and  β3 > 0.  
Is the estimate of  β2 biased up or biased down? ______  
Put differently, is omitted variable bias positive or 
negative? _______________
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1/5/2023

2

When not to worry

But it seems like we always omit some variables from 
regression equations.  Is it ever OK to omit them?
The formula for the bias is   β3  π2 , where

W  =  β1 +  β2 E  +  β3 A +  εW ,
A  =  π1 +  π2 E  + εA .

So no bias if either  β3 = 0  or π2 = 0.  In words, there 
is no bias if either

When not to worry:  example

Again, suppose we have
W  =  β1 +  β2 E  +  β3 A +  εW ,

A  =  π1 +  π2 E  + εA .
Suppose  E  is randomly assigned.  
Then  A  and  E  are uncorrelated and π2 = 0.  
So omitted variable bias  β3  π2 = _______. 
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ERROR TERM CORRELATED 
WITH REGRESSOR

• What key assumption, if violated, 
causes LS estimates to be biased 
and inconsistent?

Key assumption

• Suppose we are trying to fit a model like
yi = b1 + b2 xi + ei

• A key assumption when using ordinary least 
squares (OLS) is:

E(ei|xi) = 0 .
• Value of error term ei is not affected by value 

of regressor xi.
• Or,  xi is uncorrelated with all other 

unobserved factors that affect  y  (in ei).

Technical meaning of assumption: 
E(ei|xi) = 0

• This assumption 
implies  E(eixi) = 0 .

• If  xi is viewed as a 
random variable, then 
this further implies
Cov(xi,ei) = 

Corr(xi,ei) = 0.

x

y

Graphical meaning of assumption:
E(ei|xi) = 0

• Data are scattered 
evenly on either side 
of regression line.

• Scattering is unrelated 
to value of  xi .

x

y

What if assumption were violated, 
with Cov(xi,ei) > 0?

• Suppose xi and ei are 
positively correlated.

• Then observations 
tend to be above line 
for large xi, but below 
line for small xi.

• So LS slope estimate is 
biased __________.

x

y

What if assumption were violated, 
with Cov(xi,ei) < 0?

• Suppose xi and ei are 
negatively correlated.

• Then observations 
tend to be below line 
for large xi, but above 
line for small xi.

• So LS slope estimate is 
biased __________.

x

y
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Omitted variable bias (OVB) 
is an example of  E(ei|xi) ≠ 0

• Suppose  y = earnings and 
x = schooling.

• Suppose ability also 
affects earnings, but is 
omitted from equation.

• Anything omitted is in  ei .
• So if  x  and ability are 

positively correlated, then 
Cov(xi,ei) > 0.

• OLS slope estimate is 
biased __________.

x

y

Selection bias 
is an example of  E(ei|xi) ≠ 0

• Suppose  y = test score 
and x = attends charter 
school.

• Suppose students in 
charter schools are more 
motivated or have more 
involved parents.

• “Motivation” is in  ei .
• So then Cov(xi,ei) > 0.
• OLS slope estimate is 

biased __________. x

y

0            1

Endogeneity
is an example of  E(ei|xi) ≠ 0 

• Suppose we wish to 
estimate supply 
equation for corn:
Q = b1 + b2 Pi + ei

• Supply depends on 
other things beside 
price:  weather, pests, 
etc.  These are in  ei .

Q

P S

Endogeneity
is an example of  E(ei|xi) ≠ 0 (cont’d) 

• Economic theory says 
Q and P are jointly 
determined by supply 
and demand, so P is 
endogenous.

• Suppose ei is negative 
(bad weather).

• Then Q decreases and 
P ________________. Q

P

D

S

Endogeneity
is an example of  E(ei|xi) ≠ 0 (cont’d) 

• Alternatively, suppose 
ei is positive (good 
weather).

• Then Q increases and 
P ________________.

• So Cov(Pi,ei) < 0.

Q

P

D

S

Endogeneity
is an example of  E(ei|xi) ≠ 0 (cont’d) 

• When we estimate 
supply equation for 
corn:
Q = b1 + b2 Pi + ei ,
we have Cov(Pi,ei) < 0.

• LS slope estimate is 
biased __________.

x = P

y = Q
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Conclusions

• A key assumption for ordinary least squares is 
E(ei|xi) = 0 .

• That is,  xi is __________________ with all 
other unobserved factors that affect  y  (in ei).

• If violated, OLS slope estimator is _________.
• Examples of violations include

• Omitted variable bias
• Selection bias
• Endogeneity
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INSTRUMENTAL VARIABLES

• What is the method of 
“instrumental variables”?

Error term correlated with regressor

• If unobserved error 
term is correlated 
with regressor, OLS 
slope estimator is 
biased.

• OLS is also 
inconsistent, meaning 
problem does not go 
away as sample size 
increases.

x

y

What to do?

1. If possible, make  x  randomly assigned, so 
that  x  is not correlated with error term (or 
anything else).

2. If possible, include relevant control variables
as extra regressors.

3. If possible, use method of instrumental 
variables.

What is an instrument?

• Suppose we are trying to estimate the slope 
coefficient of  x  in

yi = b1 + b2 xi + ei .
• An “instrument” is a variable that is 

correlated with  xi but not with  ei .

Instrumental variables (IV) estimation

• Suppose  wi is an instrument.
• First, estimate  1 and  2 in this “first-stage” 

equation:
xi = 1 + 2 wi + e1i  .

• Save the fitted values  𝑥 .
• Second, estimate  b1 and  b2 in this “second-

stage” equation:
yi = b1 + b2 𝑥 + e2i .

IV chain from cause to effect

w → x → y
Equation Relationship
First stage
Second stage (LATE)*
Reduced form (ITT)**

*The second-stage equation is the relationship of interest, sometimes called 
the “structural equation.”  If the instrument is randomly assigned, the second-
stage coefficient of  x  is called the “local average treatment effect” (LATE).
**If the instrument is randomly assigned, the reduced-form coefficient of w
is called the “intention to treat effect” (ITT).
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Properties of IV estimators

• It can be shown that second-stage estimators 
are ___________________, meaning they 
converge in probability to true values of b1
and b2 as sample size increases.

• However, IV estimators may have some bias 
in small samples.

• Also, IV estimators have larger variance than 
OLS estimators.

Extension:  “two-stage least squares”

• Strictly speaking, term “instrumental 
variables” is usually applied only to case of 
________ regressor and one instrument.

• But method can be extended to situations 
with ___________ instruments and controls.

2SLS:  example

• Suppose we are trying to estimate b2 in
yi = b1 + b2 x2i + b3 x3i + ei ,

where  x3i is a control variable.
• We fear that  x2i is correlated with  ei .
• But we have two instruments  w1i and w2i

that are correlated with  x2i but not with ei .

2SLS:  example (cont’d)

• First, estimate  1,  2,  3 in this “first-stage” 
equation:

x2i = 1 + 2 w1i + 3 w2i + 4 x3i + e1i  .

• Save the fitted values  𝑥 .
• Second, estimate  b1 and  b2 in this “second-

stage” equation:
yi = b1 + b2 𝑥2 + b3 x3i + e2i .

Computing IV estimates

• If you compute first and second stage using 
regress (or Excel), coefficient estimates will 
be correct but standard errors will be wrong.

• Instead, use special STATA command:
ivregress 2SLS y x3 (x2=w1 w2),

first vce(robust)
which automatically computes standard 
errors correctly.

Finding good instruments
(the hard part)

An “instrument” is a variable that is correlated 
with  xi but not with  ei .  This means:
1. Has causal effect on  x.
2. Is unrelated to any omitted variables (in ei ).
3. Can be excluded from equation explaining  y.  

That is, instrument affects  y  only through  x.

Angrist, J. D., & Pischke, J.-S. (2015). Mastering 'metrics:  the path from cause to effect. 
Princeton, New Jersey: Princeton University Press, p. 106.
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Example:  omitted variable bias (OVB)

• Suppose  y = earnings and x = schooling.
• Suppose schooling correlated with “ability” 

(in  ei ), so Cov(xi,ei) > 0.
• Need instrument that affects earnings only 

through schooling.
• Possible instrument:  

_____________________________.

Example:  selection bias

• Suppose  y = test score and x = attended 
charter school (dummy variable).

• Suppose charter-school attendance 
correlated with “motivation” (in  ei ), so 
Cov(xi,ei) > 0.

• Need instrument that affects test score only 
through charter-school attendance.

• Possible instrument:  ___________________ 
____________________________________.

Example:  endogeneity

• Suppose  y = quantity of corn supplied and 
x = price of corn.

• Suppose price negatively correlated with 
“good weather” (in  ei ), so Cov(xi,ei) < 0.

• Need instrument that affects quantity 
supplied only through price.

• Possible instrument:  
______________________.

Beware weak instruments

Does instrument really have causal effect on  x?
• If effect is weak, IV estimates are too biased 

in small sample to be useful.
• Check first-stage regression:

xi = 1 + 2 w1i + 3 w2i + 4 x3i + e1i  .

• Rule of thumb:  F-statistic (testing 
H0: 2=3=4=0) should be at least _______.

Beware invalid instruments

Is instrument really unrelated to any omitted 
variables (in ei )?
• If instrument not valid, then IV inconsistent. 
• If instrument is randomly assigned, no 

worries!
• Otherwise, perhaps check correlation of 

instrument with included controls.

Conclusions

• The method of instrumental variables (IV) is a 
technique for estimating equations where 
error term  ei is correlated with regressor  xi .

• An “instrument” is a variable that is 
correlated with  xi but not with  ei .

• IV estimators can be computed in two stages.
• If instrument is valid and not weak, IV 

estimator is consistent even when OLS is not.
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WRITING AN 
ECONOMETRIC

RESEARCH PAPER
Organization and writing style

Parts of a research paper

Title page
1. Introduction
2. Literature review
3. Data
4. Methodology
5. Results
6. Conclusions

References
Figures and tables
Data appendix

Objective writing style

• Objective, impersonal. Avoid “I” and “me.”  Never 
discuss personal feelings.

• Passive tense is perfectly acceptable, as in scientific 
writing.

• Seek to convey that you did a careful job, and that 
anyone else who did a careful job would come up 
with the same answers.

• Never overstate your conclusions.
• Always acknowledge limitations.

Help the reader

• Research writing can often be dense, difficult 
reading.  Easy for reader to get lost.

• Use transitions and signposts, so reader 
understands where you are going.

• Use topic sentences for each paragraph and 
introductory paragraphs for each section.

• Last sentence of paragraph should tie things 
together.

• Last paragraph of each section should restate key 
points and lead reader to next section.

Title page

• Title
• Author
• Affiliation – where to the find the person.
• Date
• Abstract – short summary of paper, lets readers 

know whether it is relevant to them.
• Keywords – included in data bases like EBSCO or 

ECONLIT.
• Acknowledgements

1. Introduction

• Frame the question(s) to be addressed.
• What is general topic and why is it interesting?
• NEVER say “I chose this topic because…”
• Instead, say “This topic/question/issue is 

interesting/important/relevant because…”

• Last paragraph should describe the rest of the 
paper, foreshadowing your method and results.

• Sometimes if paper is very long, introduction is self-
contained condensed version of paper for readers 
who don’t have time to read entire paper.
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2. Literature review

• Why necessary?
• Research is a social activity.
• We push knowledge forward if we can place our 

research in context of what is already known.
• Discuss at least three prior articles.
• Don’t make a list.  Instead, tell a story.
• Reader should sense how each article you discuss 

relates to others.
• Sometimes best organization is chronological, each 

article responding to previous article(s).

3. Data

• Explain where data came from.
• Cross-section, time-series, panel or pooled?
• Unit of observation?  (E.g., county and year)
• Discuss table of variable definitions and table of 

descriptive statistics.
• Distinguish dummy variables from others.
• Goal:  reader should be able to understand text 

without flipping to table, and understand table 
without flipping to text.

4. Methodology

• What is outcome variable?  What is treatment 
variable(s)?  What are controls?

• What functional form will you use—logs, per-capita 
units, squares, and interactions?

• Write out the equation to be estimated on a separate 
line, centered.  Example:

ln(wage) = β1 + β2 educ + β3 exper + β4 exper2 .
• Will estimates have a causal interpretation?

• If so, why?
• If not, why might there be omitted variable bias or selection 

bias?

5. Results

• Estimate more than one equation, varying the control 
variables, and present them in a table.

• If you present only one estimated equation, reader 
might suspect that you cherry-picked results.

• Discuss coefficient estimates—do signs and values 
make sense?  Are they statistically significant at 5%?

• Call attention to coefficient of treatment variable.  
Explain how it should be interpreted.  Example:

• “The estimated coefficient of schooling shows that an 
additional year of schooling causes wages to rise by 9 
percent.”

6. Conclusions

• Restate the research question and how you 
addressed it (in case reader has forgotten).

• Explain what answer(s) can now be given, 
according to your analysis.

• Recognize any limits to your answer(s).  Examples:
• “A 95% confidence interval for the coefficient is wide 

enough to include much higher and much lower 
estimates.”

• “This estimate assumes no ability bias.”

References

• Start on a new page.
• Include all papers you cited and data sources, but 

nothing else (no “suggested readings”).
• Alphabetical order by author, using APA format (see 

http://library.albany.edu/cfox).  Examples:

Atkinson, A. B., Piketty, T., & Saez, E. (2011). Top incomes in the 
long run of economic history. Journal of Economic Literature, 
49(1), 3-71.
Goldin, C., & Katz, L. F. (2008). The race between education and 
technology. Cambridge, Massachusetts: Harvard University 
Press.
Semega, J. L., Kollar, M. A., Creamer, J., & Mohanty, A. (2019). 
Income and poverty in the United States: 2018. Available at 
www.census.gov .
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Figures and tables

• Traditionally, figures and tables were always put at 
the end of the paper, due to limitations of word 
processors.

• Now it is often OK to put them in the text, on the 
next page after they are first referenced in the text.

• Should start at top of page.

Data Appendix

• Some readers may wish to replicate your results.
• Data appendix documents your data collection well 

enough so that intelligent reader could do so.
• Explain how and when you obtained data, including 

websites and dates accessed.
• Explain what observations you dropped from 

analysis and why.
• End with this offer:  “Data and Stata code used to 

compute the estimates are available from the 
author on request.”

Revising

• After finishing a draft, let it sit for a day and take a 
second look before submitting it.

• Errors and unclear passages will suddenly appear!
• Always check and fix typos, spelling errors, and 

grammatical errors before asking someone else to 
read your paper.

• Professionals ALWAYS present a paper at seminars 
and conferences, ask peers to read it, and revise it 
multiple times before sending it to a journal.
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